Issue 59631

Summary: TOC hyperlink malfunctions if the headings begin with a manual number
Product: Writer Reporter: raindrops <na1000>
Component: uiAssignee: Oliver Specht <os_ooo>
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: eric.savary, issues
Version: OOo 2.0   
Target Milestone: ---   
Hardware: All   
OS: Windows NT   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
small sample file none

Description raindrops 2005-12-21 08:30:11 UTC
If the headings have a manually inserted number in front, the TOC malfunctions.
(This happens if the number is inserted manually, NOT based on an outline.)

Step-by-step procedure to replicate the problem:

1. Create a odt file with some text
2. Create 2-3 levels of headings (Heading1, Heading2, etc.)
3. In the text for a few headings, insert a number. 
   (e.g. "1. Introduction").
4. Insert a TOC for the document. 
5. Insert hyperlinks in the TOC by adding "LS" and "LE" to the top-level entry
of TOC, and then clicking on the "All" button. 
6. Click on a line of TOC that does not have such a number. Writer jumps to the
corresponding page in the document, which is the correct expected behavior. 
7. Next, click on the entry of the TOC that contains a manually inserted number. 
The Writer jumps to the top of the CURRENT page; not to the actual text.

This is a defect because the behavior of the hyperlink should not depend upon
what is the content of the heading.
Comment 1 michael.ruess 2005-12-21 11:20:34 UTC
Created attachment 32625 [details]
small sample file
Comment 2 michael.ruess 2005-12-21 11:23:10 UTC
MRU->OS: see attached document. When a Heading has a manual number, it is not
possible for Writer to solve the adress of the hyperlink in the TOC correctly.
Comment 3 paradigm 2008-12-02 04:14:55 UTC
Also effects OOo 3.0.0
Comment 4 eric.savary 2008-12-02 11:45:26 UTC
duplicate

*** This issue has been marked as a duplicate of 29858 ***
Comment 5 eric.savary 2008-12-02 11:45:39 UTC
closed