Issue 59846

Summary: New record in a subform is not linked to the form record (as Access does)
Product: Base Reporter: gissi <emanuele.gissi>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 2.0.1   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Example of a simple subform
none
I am astonished. This DB works as it should!!! I could not find any difference in settings... none

Description gissi 2005-12-28 13:14:26 UTC
Please, follow with the included example test2.odb 
 
1) Create a new db (internal db engine)  
2) Create two tables (book, writer) as in the included example test2.odb 
3) Create the 1:n relation: writerId -> bookWriter  
4) Create a form and its subform with the wizard (fWriter) 
   The connected fields are writer.writerId (master), book.bookWriter (slave) 
5) Enter a new book record in the subform for the record writerId=1 (Giovanni 
Pascoli)  
  
The foreign key "book.bookWriter" does not default to writer.writerId=1, 
it defaults to 0. So the subform creates a new record that is not connected 
with the record displayed in the form. 
 
In MSAccess the foreign key defaults to the connected value from the form. 
I humbly think this would be the right choice. 
 
Or, did I lose something? (Thanks for OO.o 2, it's my daily tool!)
Comment 1 gissi 2005-12-28 13:16:26 UTC
Created attachment 32747 [details]
Example of a simple subform
Comment 2 gissi 2005-12-28 14:38:33 UTC
Created attachment 32749 [details]
I am astonished. This DB works as it should!!! I could not find any difference in settings...
Comment 3 drewjensen.inbox 2005-12-29 14:59:09 UTC
I have duplicated the problem in a different test database.

The issue seems to be only when type BIGINT is used with IDENTITY for an auto
generated PK. 
Comment 4 marc.neumann 2006-01-02 10:58:35 UTC
Hi,

I can reproduce this, reassign it to the right developer and set target.

Bye Marc
Comment 5 versurppersio 2010-11-10 21:02:10 UTC
Created attachment 73603
Comment 6 Marcus 2017-05-20 10:47:59 UTC
Reset assigne to the default "issues@openoffice.apache.org".