Issue 60053

Summary: Captioning in frames is defective
Product: Writer Reporter: raindrops <na1000>
Component: formattingAssignee: michael.ruess
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 2.0.1   
Target Milestone: ---   
Hardware: All   
OS: Windows NT   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description raindrops 2006-01-05 08:10:52 UTC
Captioning in frame is defective.

*************************************************
Note:
After raising Issue 60016, I conducted some experiments, and found that the
problem is more fundamental.

In fact, it is related to how caption is treated WITHIN a frame.

Since this is no more related to linked frames, I am raising this issue separately.
*************************************************
In fact, captions in frames suffer from multiple problems:

1. You can enter any number of captions in a single frame!
Just select the "caption" command from the context menu and go on entering new
strings. All of these captions will add up in the same frame.

Writer does not block this, neither does it prompt you whether to replace the
existing caption.

2. When you are in a frame that already has a caption, the "Caption" dialog does
not serve as a caption editor.
> It does not reflect the current caption, which you can edit.
> Whatever you enter in the "Caption" dialog goes to the frame as a new
(ADDITIONAL) caption.
> The only way to edit the caption is to click inside the frame and edit it.

3. You can click inside the frame and edit the caption like any other text.
If you see the "caption" context menu after that, the new changes are not
reflected. In fact, the field remains blank.

4. You can click anywhere around the caption and add text before or after it. 
After such editing, your caption can be easily lost in the text.

In other words, captions are neither protected nor set apart so that they can
stand out in comparison with the contents of the frame.

5. You can click inside the frame and DELETE a caption. 
Again, the "Caption" dialog will not show any difference.
Comment 1 michael.ruess 2006-01-05 10:49:43 UTC
Same as issue 40957.

*** This issue has been marked as a duplicate of 40957 ***
Comment 2 michael.ruess 2006-01-05 10:56:21 UTC
Closing dup.