Issue 60140

Summary: merge cells button gets invalid states
Product: Calc Reporter: norbert2 <norbert.notz>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P4 CC: issues, lars_o_hansen
Version: OOo 2.0.1Keywords: oooqa
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
screenshot none

Description norbert2 2006-01-06 17:43:10 UTC
Hi,

I guess you agree that the merge cell button in the toolbar should only be
enabled if there is a continuous selection of two ore more cells. Am I right?

--------------------------------------------------------
1.

- Please open a blank spreadsheet
- hold down the left-mouse-button (lmb) over cell A1
- move the mouse over A2 (while still not releasing the lmb): note that the
merge cell button is now properly enabled
- move the mouse back to A1: note that the button is still enabled! Also after
releasing the lmb.
--------------------------------------------------------
2.

An alternative way to reproduce the same bug:
- open a blank spreadsheet
- click the format brush button
- click into any cell: now you also have one selected cell with the merge button
enabled.
--------------------------------------------------------


Note that 2 single clicks (not a double click) while holing down CTRL into one
cell also selects this cell, but with the merge button properly disabled.




--------------------------------------------------------
3.

- open a blank spreadsheet
- select a rectangle field of cells using the mouse, for example A1:C5: the
merge button is properly enabled
- make a single clicks while holing down CTRL
- release and re-hold-down CTRL over B3
- do a second single click over B3: Now we have a continuous selection with a
disabled merge button!

Please have a look at the attached screenshot.


This seems to be a bit sporadic. Maybe it depens on the delay between the CTRL
release and re-hold-down
It looks like waiting long enough that the merge button disables after releasing
CTRL leads to the bug.
Lower delays so that the merge button does not disable seem to not lead to the bug.


This issue could be related to issue 55112, the slow GUI update introduced in
OOo 2.0.

And/or related to issue 46158 which still exists in OOo 2.0.1 but has been
closed as WORKSFORME by fst because he was unable to reproduce it.
--------------------------------------------------------









found on
SO8 SuSE 9.3
SO8 WindowsXP
OOo 2.0.1 WindowsXP
Comment 1 norbert2 2006-01-06 17:43:46 UTC
Created attachment 32977 [details]
screenshot
Comment 2 norbert2 2006-01-06 17:46:00 UTC
(I mean SO8 Product Update 1. But I guess it's the same with unupdated SO8.)
Comment 3 lars 2006-01-06 19:43:31 UTC
confirmed on Windows XP Pro SP2 with OOo 2.0.1
Comment 4 frank 2006-02-01 15:14:51 UTC
Hi Niklas,

please have a look at this one.

Frank
Comment 5 niklas.nebel 2006-07-07 19:23:35 UTC
changing target
Comment 6 Martin Hollmichel 2007-11-09 16:53:08 UTC
change target from 2.x to 3.x according to
http://wiki.services.openoffice.org/wiki/Target_3x
Comment 7 Marcus 2017-05-20 11:11:35 UTC
Reset assigne to the default "issues@openoffice.apache.org".