Issue 60340

Summary: Writer crashes/unresponsive while merging table cells
Product: Writer Reporter: raindrops <na1000>
Component: editingAssignee: michael.ruess
Status: CLOSED FIXED QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P2 CC: issues
Version: OOo 2.0.1   
Target Milestone: ---   
Hardware: All   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description raindrops 2006-01-11 08:43:23 UTC
While merging cells of a table, Writer becomes unresponsive or crashes.

I have a 300+ pages odt file, in which I have used a two-column table to control
the text flow: Its left column acts as margin; and the right column holds the
contents (text, tables, images, etc). We will call this "the outer table" ("OT"
in short) in this discussion.

The document was actually converted from a Word document (I just opened the
"doc" file in Writer and saved it as "odt"). Currently I am working on this odt
file with Writer. 

The original file was made with Word 2000, which used to crash when a single row
of a table exceeds =>2 pages. Therefore I had to make sure that rows do not
cross a page; by dividing the content into smaller rows.

This lead to two problems:
1. I had to leave blank space on many pages when the rows do not fit in a given
2. When I edited the document, I had to re-adjust the rows across all pages.

So, when I changed over to Writer, I wanted to merge all rows of OT to avoid the
hassle. I started out by merging multiple cells in the left column and then
merging multiple cells in the right column. But Writer crashed often, or became
unresponsive.(it has crashed more than 60 times in the last week). Now I am down
to merging only two cells at a time but the Writer continues to crash.



The exact symptoms are as follows:

1. Crash: 
As soon as I select the cells and click on the "merge" button ion the table
toolbar, Writer vanishes, and the OOo recovery dialog starts.

2. Unresponsive: 
The screen rapidly alternates between "all white" and regular display
(frequency:  about 0.5 seconds). At this time, Writer stops responding to
keyboard/mouse. It does not even allow me to close the document/window by
right-clicking on the task button and selecting the "Close   Alt+F4" menu
option. I have to use the task manager to kill OOo.

Only on two separate occasions I could see something more:
>> Some images jumped across the page and went to the next page, and then jumped
back. This cycle repeated endlessly.
>> I had put some ellipses (using the "Drawing" toolbar) on these images to mark
particular parts of the images. These ellipses were also seen jumping across the
page, but not in sync with the images themselves. (It appeared as if the
ellipses were trying to chase the images and trying to catch up with them!)
Probably the same thing happens in other cases too, but since it is not
happening on the current page, I can't see it. (As mentioned earlier, I can't
leave the current page because OOo stops responding to mouse and keyboard.)

My own impression is that when there is a long table (spread over multiple
pages) in a document, Writer tries to re-arrange the contents over different
pages. Normally this should be over in a single iteration, but somehow this
optimization takes multiple passes, finally resulting into an endless loop.

The situation is compounded because Writer does not have any "highest-priority"
controls that can interrupt this cycle. Each time I have to kill Writer using
Task manager.
Although the problem occurs very often, some of the cells CAN be merged without
any problem. But I am unable to predict which of the cells will cause a problem.

Anyhow I have identified one specific location in the document that gives this
problem very consistently. It could help troubleshooting.

This file is confidential, so do not post it or share it publicly. 

Sending the file  through email is problematic. I have FTP'd the earlier version
of this file to Lars, so I could send this latest version to him.
Else, please let me know whom to send the file. 

I can provide the recovery report also, but I do not work online; so it will
have to be sent as an email. Please suggest if there is anything else I can do
with this report.


1. When the problem occurs, the task manager shows that the CPU load is steady,
almost at 50%. 

2. I am working on a 3 GHz Pentium 4 PC with HT, Intel 915GAV motherboard and 1
GB/400 MHz DDR RAM. I do NOT run any other application while using OOo.

3. I have not observed any abnormalities except one: While instaling GIMP, two
of the dlls related to XML parsing were renamed by that installer. I do not know
if this is a factor in this case.
Comment 1 michael.ruess 2006-01-11 10:59:39 UTC
Sending the Error report via mail won't give us any help in debugging. It must
be send via the crash-recovery tool, so that it can be connected to the debug
info via the crash report database.

Please send the document to, I will handle this document
confidentially. Thanks in advance!
Comment 2 raindrops 2006-01-11 12:52:30 UTC
Well, the recovery wizard allows the user to see what report is being sent. I
was thinking of enclosing a soft copy of that same report.

My other PC IS connected to Internet, but it is behind a firewall; and so it
cannot connect to your servers.

Pity we are losing so many chances of collecting accurate reports--Probably many
reporters would be facing similar problems.

Probably a rethinking is required on how to provide an indirect interface to the
data-collection tool. 
As stated earlier, I cannot send this particular file because my email reports
"this document contains no data". I tried to send it as doc/odt/rar/zip, but the
problem remains.

Last time, I had tried to send doc/odt/zip/rar files through,
but that channel too reports the same error. 

Only ftp works. So if you let me have a temporary username+password, I can send
it across.

Comment 3 michael.ruess 2006-01-11 14:01:49 UTC
Perhaps it is possible to you to cut down the document to the table, which will
cause the problem and then send the shorter document?
Comment 4 raindrops 2006-01-12 04:47:39 UTC
Yes, I'll try that (by next week).

BTW the last time I tried that, the problem vanished. I had to send the entire
file to Lars. So in this case too, I thought it's better to keep all factors in
their natural state.
Comment 5 michael.ruess 2006-01-27 14:56:18 UTC
MRU->FME: the problem is reproducable. I gave you the shorter document which is
reduced to the one table. There, select the cells A2 and A3 merge these -> crash
I have forwarded you also the debug information.
Comment 6 frank.meies 2006-01-31 09:28:00 UTC
FME: Fixed in cws swqbf51, tblsel.cxx rev.
Comment 7 frank.meies 2006-01-31 15:21:04 UTC
FME: Ready for QA.

re-open issue and reassign to
Comment 8 frank.meies 2006-01-31 15:21:46 UTC
reassign to
Comment 9 frank.meies 2006-01-31 15:22:35 UTC
reset resolution to FIXED
Comment 10 michael.ruess 2006-02-03 09:49:29 UTC
Verified fix in CWS swqbf51.
Comment 11 raindrops 2006-02-03 13:12:02 UTC
MRU, did you verify for both behaviors (hang AND crash)? 

Both happened in my case.

Comment 12 michael.ruess 2006-02-03 13:28:01 UTC
I could not see a hang here; only the "blocking" by Writer being heavily
occupied with formatting process (which is normal).
If you also have a "real" hang/loop, it is a different bug which should be filed
ina seperate issue.
Comment 13 raindrops 2006-02-06 05:01:47 UTC
OK I will check this in 2.0.2 and decide whether the other part is still there.

Comment 14 michael.ruess 2006-02-09 14:40:53 UTC
Checked in 680m156.
Comment 15 raindrops 2006-03-07 16:44:50 UTC
checked in 2.0.2 RC4, installed on Win XP SP-2. 

Merged 3 cells in the left column, (these cells spanned over 3 pages). After
some time, Writer went into "wait" state, and even half an hour later it did not
recover. I will try that again and let you know the result.

But I can't positively correlate that with THIS bug, because Writer also crashes
with the sample file by itself (without doing any edit operation at all), as I
have highlighted in the other bug (Issue 61557).
Comment 16 michael.ruess 2006-03-08 08:18:33 UTC
If you can reoproduce the problem another time, please do not reopen this issue.
File a new one and tell us which cells in which table you tried to merge. It is
a different thing than we fixed with this issue. Thanks for your patience.