Issue 60467

Summary: OOoBean: no keyboard events
Product: App Dev Reporter: joachim.lingner
Component: apiAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: hdu, issues, joachim.lingner, michael.cziebalski, raymond.steele, tobias.krause
Version: 3.3.0 or older (OOo)   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Java test program
none
compiled Java program none

Description joachim.lingner 2006-01-13 06:06:51 UTC
This bug is very similar to i49454. When the test is started a second time (or
more) the window does not receive keyboard events. 

    public static void main (String[] args) {
        try {
              OOoBean b = new OOoBean();
        b.setSize(300,300);
        b.loadFromURL("private:factory/swriter", null);
               b.setSize(300,300);  
               
        java.awt.Frame f = new java.awt.Frame();
        f.addWindowListener(new WindowAdapter() {
            public void windowClosing(WindowEvent e) {
                System.exit(0);
            }
        });
        f.add(b);
        f.setSize (600, 600);
        f.show();
        b.aquireSystemWindow();
        //b.stopOOoConnection();
        } catch(Exception e) {
            e.printStackTrace();
        }
    }

I ran the program from within netbeans and the bug could be reproduced every
time. The first time the program runs everything works, but the following times
it does not. This could mean that in VCL something  is damaged permantly on the
first time the program runs.
Comment 1 joachim.lingner 2006-01-31 12:51:06 UTC
Created attachment 33733 [details]
Java test program
Comment 2 joachim.lingner 2006-01-31 12:57:54 UTC
To run the test program you need to set the classpath properly:

> set
CLASSPATH=.;d:\office\program\classes\officebean.jar;d:\office\program\classes\jurt.jar;d:\office\program\classes\java_uno.jar;d:\office\progra
m\classes\unoil.jar;d:\office\program\classes\ridl.jar;d:\office\program\classes\juh.jar

> java KeyTest

Comment 3 joachim.lingner 2006-01-31 15:26:20 UTC
Created attachment 33742 [details]
compiled Java program
Comment 4 joachim.lingner 2006-01-31 15:32:48 UTC
I tried it on Linux but could not reproduce this behaviour. It seems to be a
windows only problem.
Comment 5 hdu@apache.org 2006-01-31 15:56:47 UTC
.
Comment 6 joachim.lingner 2006-03-01 14:25:18 UTC
*** Issue 60468 has been marked as a duplicate of this issue. ***
Comment 7 hdu@apache.org 2006-07-12 14:53:09 UTC
Retargeting...

Is this still reproducable?
Comment 8 joachim.lingner 2006-07-12 14:58:01 UTC
The test program is attached, so you can verify it any time :)
Comment 9 joachim.lingner 2006-07-13 10:21:51 UTC
Issue still exist on m175.
Comment 10 Martin Hollmichel 2007-11-09 17:28:28 UTC
set target from 2.x to 3.x according to
http://wiki.services.openoffice.org/wiki/Target_3x
Comment 11 mci 2008-05-13 17:06:29 UTC
adding mci to CC...
Comment 12 joachim.lingner 2008-05-14 07:08:56 UTC
cc ing tkr
Comment 13 hdu@apache.org 2008-05-14 09:53:45 UTC
@AS: you mentioned some tricks that framework uses for netbeans integration: JL needs to override some 
methods. Please explain in detail and reassign.
Comment 14 rjsteele 2012-10-16 04:11:10 UTC
Has this been resolved? I am experiencing the same problem on Solaris 10 x86 OpenOffice 3.3.
Comment 15 Ariel Constenla-Haile 2012-10-16 09:14:19 UTC
(In reply to comment #14)
> Has this been resolved? I am experiencing the same problem on Solaris 10 x86
> OpenOffice 3.3.

No, the status is CONFIRMED, that is not FIXED.