Issue 60624

Summary: D&d-shortcut to paste cells without overwriting others
Product: Calc Reporter: rabauke <sven.burmeister>
Component: editingAssignee: spreadsheet <spreadsheet>
Status: CLOSED DUPLICATE QA Contact: issues@sc <issues>
Severity: Trivial    
Priority: P3 CC: issues, lars_o_hansen
Version: OOo 2.0Keywords: oooqa
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: FEATURE Latest Confirmation in: ---
Developer Difficulty: ---

Description rabauke 2006-01-16 09:55:19 UTC
In order to move rows/cells/comuns, it would be very convenient to have the 
possibility to drop them somewhere without them overwriting other cells, but 
creating new cells/coluns/rows instead. 
 
For example: 
Row 1 
Row 2 
Row 3 
Row 4 
 
Select row 2 and drop it on row 4. Row 4 will be overwritten. Instead one 
should be able to press some shortcut, e.g. ALT in order to get the following: 
 
Row 1 
Row 3 
Row 2 
Row 4 
 
It is worth discussing, whether it might be better to get the following when 
just pressing ALT: 
 
Row 1 
<empty> 
Row 3 
Row 2 
Row 4 
 
So one would have to press ALT+CTRL to copy and create a new line for the 
drop, or ALT+SHIFT to move, i.e. leave no empty space and create a new line 
for the drop. 
 
This is very helpful when re-arranging tables, as it skips two clicks per 
action, i.e. right-click on row, add new line.
Comment 1 lars 2006-01-16 21:25:33 UTC
this is basically a duplicate to issue 60079

*** This issue has been marked as a duplicate of 60079 ***
Comment 2 rabauke 2006-01-16 21:38:32 UTC
Are you kidding? This bug was filed for spreadsheet not database. I did not 
even mention that term. 
 
Please mark it as dup of issue 14007, if at all, since this issue here asks 
for d&d by clicking on the row-numbers rather than cells. 
Comment 3 lars 2006-01-21 16:04:59 UTC
.

*** This issue has been marked as a duplicate of 14007 ***
Comment 4 frank 2006-03-07 09:46:41 UTC
and closed