Issue 61685

Summary: Provide a means to remove all easter eggs from release versions
Product: General Reporter: lars.nooden
Component: codeAssignee: AOO issues mailing list <issues>
Status: CLOSED OBSOLETE QA Contact:
Severity: Trivial    
Priority: P3 CC: ace_dent, issues, rb.henschel, sigrid.carrera, www.openoffice.org
Version: OOo 2.0Keywords: oooqa
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description lars.nooden 2006-02-06 14:45:30 UTC
Provide a means to remove all the eastereggs from release versions.  

Just saying to remove the offending bits from the source code and recompile
it, is not an appropriate solution for the *end users or sysadmins*.  

It is perfectly reasonable to expect that a defect be addressed as part of the
development team.  

Making it possible for an admin to block all Easter Eggs would be a quick fix. 

If it is such an important issue to retain the eggs, and the only option you are
willing to entertain is that the end users or sysadmins to maintain their own
fork, then provide instructions on how to do so.
Comment 1 ace_dent 2006-02-06 15:27:04 UTC
I fully support the proposal to remove the Easter Eggs. Since they are present
in at least Writer as well as Calc, I have changed component to framework. Also
changed to Enhancement.

Regards,
Andrew
Comment 2 Olaf Felka 2006-02-06 15:32:17 UTC
reassigned. If there are no other problems in OOo.......
Comment 3 lars.nooden 2006-02-06 15:40:06 UTC
The pictures of the developers could moved to 'about openoffice.org' or the help
file, or even retained, but the interactive eggs (e.g games) are the ones that
would be disruptive in a classroom environment.

Comment 4 giacobbej 2006-02-06 16:20:13 UTC
Not only disruptive in a classroom environment, but also contributing (however
small) to the size of the OO.o codebase. No matter how "cute' or "funny" these
hidden games are, the fact is they are contributing to the size of the OO
codebase and binaries. Heck, they're even in StarOffice 8! 

The Easter eggs need to go. That joke stopped being funny around 1986.

Regards,
Jeff

Comment 5 stenito 2006-02-06 16:34:39 UTC
The problem here is that even though there are a lot of reasons why there should
be no easter eggs and none why they should be in the code, there is no means to
obtain what is reasonable. 
In an environment like this one, with a product like this one, it should be
possible to use argumented decissions. Pro's versus con's. 

The only pro till now is that it is fun. For whom?

Steven P.
Comment 6 ace_dent 2006-02-06 17:11:51 UTC
->'larsnooden',

I have just noticed that you have also raised Issue 61667 & Issue 61683. Please
do not deliberately raise duplicate issues to force your viewpoint- it only
creates more work for QA and annoys developers!

It seems 'pjanik' / 'of' has let this Issue pass to Requirements. Hopefully this
Issue will stay open, to allow for a *calm* and reasonable discussion. The
following may help progress the Issue:
- In this Issue record the various known Easter eggs.
- Calculate the actual disk space overhead for an installed copy of OOo
(Windows?) due to these Easter eggs (I suspect less than 2MB- but better if it
was 0MB!)
- With this information run a poll over at OOo Forums, to gather what the public
consensus is.

Regards,
Andrew
Comment 7 lars.nooden 2006-02-06 17:27:10 UTC
Thanks, Andrew.  

If you look at issues 61667 & 61683 (ok, at least the former) I did try to keep
everything under one single issue.  If you read them, I was very specifically
requested by pjanik to create a new issue each time he/she/it/they summarily
dismissed the topic.  

The problem is currently being discussed on the discuss@openoffice.org :
 http://www.openoffice.org/servlets/BrowseList?list=discuss&by=thread&from=1269476

and marketing@openoffice.org :
 http://marketing.openoffice.org/servlets/BrowseList?list=dev&by=thread&from=1270355

I, unfortunately, have been the go-between.   Alot of thought goes on in those
two lists, but unless it makes its way to this awkward piece of software, I
suspect that it counts for naught.  Please, if you haven't already, join the
discussion or at least read the archives.  

When the time comes to bring the topic to OOo Forums, please be sure to post a
notice to both marketing and discuss.
Comment 8 lars.nooden 2006-02-06 17:29:52 UTC
The "vote for this issue" link does not allow me to cast any votes for this issue.
Comment 9 ace_dent 2006-02-06 17:37:53 UTC
Some older Easter Egg Issues...
Dec' 2002: Issue 10072
Sep' 2005: Issue 54703
Sep' 2005: Issue 54876
Sep' 2005: Issue 54877
Sep' 2005: Issue 54878
Dec' 2005: Issue 59593
Comment 10 sigrid.carrera 2006-02-07 19:10:10 UTC
For the record of the already known easter eggs: 

In Calc: 
=Game("StarWars")
=Game(A1:C3;"TicTacToe")
=StarCalcTeam()

In Writer:
StarWriterTeam + F3 -button

It looks, like there have been some easter eggs removed, since I've tried all
easter eggs, mentioned in this email:
http://www.openoffice.org/servlets/ReadMsg?list=discuss&msgId=1148237 and the dt
+ F3 and the "Answer" (or better "Antwort") won't work within my version of OOo. 

Comment 11 jcausey 2006-02-09 04:37:11 UTC
I would like to lend my support to the effort to remove the Easter eggs or at
least provide a way to get rid of them (I would prefer to see them missing by
default).  At least one person has pointed out that the presence of the EE's is
a problem for a particular education market.

Looking around the Internet, I've found other indications that the presence of
EE's introduces problems with corporate customers and government agencies.  So
much so, that it appears that Microsoft(yeah, an unfortunate choice to cite as
an example) considers it grounds for termination to program EE's into its
products.  As I've reviewed the arguments thus far relative to this issue, it
has gotten me to wondering about the implications for adoption by governments
that are looking for secure products.  Major Linux vendors are working on a
variety of secured versions to meet government specs.  While most of this is
probably intended for very specific applications, if there is ever a hope that
OOo might be adopted on desktops in these agencies, getting rid of the EE's
would probably be a good move to improve the quality and security of the stack.

In addition, the presence of the EE's represents additional code that has to be
QA'ed (it is being QA'ed and not slipped by somehow, right?).  Surely OOo's
developers have better stuff to work  on than reviewing the code for these EE's.
 Likewise, it is adding additional complexity to the code.  I'd suggest checking
out this article:

http://www.informit.com/articles/article.asp?p=102181&seqNum=4&rl=1

that covers some of these issues in a much better manner than what I can
express.  Also, for some other discussion on the value of EE's, you might want
to check out the link below (be sure to read some of the comments):

http://blogs.msdn.com/larryosterman/archive/2005/10/20/483110.aspx

Thanks to the developers for considering these comments!

Jeff Causey
Comment 12 chadley78 2006-02-09 04:53:34 UTC
There are people who enjoy the EE.  The EE are a part of OOo's history, and a
part of honoring those developers who created the software.  I ask you to not
remove the EE.  Perhaps, if you have to, add a way to remove them on install of
the binary, but do not remove them from the codebase.  Virutally every major
computer program - open and closed source - from Windows to Debian to OS X to MS
Office to Adobe Creative Suite to GIMP to Firefox - has EE.  They are fun, they
are geeky-cool, they don't hurt anyone - if you don't know they are there,
they'll never bother you.  -1 vote on this issue.  This issue was right to be
closed every other time it was brought up.
Comment 13 lars.nooden 2006-02-09 09:59:30 UTC
I think I see the core of the disagreement or confusion.  I was specifically
thinking about the interactive easter eggs like the games, not the developer
snapshots and such.  

As much as I agree with the comments that eggs are 'cool', 'clever' or otherwise
amusing, they do render OOo very much less marketable in some sectors, school
classrooms in particular.  It's not about likes or dislikes.  No one has asked
whether I like them or not. I actually do.  However, they need to be removed for
certain environments.  
Comment 14 ace_dent 2006-02-09 10:16:13 UTC
A Polite Request:
At the risk of Policing this Issue, I would encourage a more technical debate.
If everyone contributes their personal arguments 'for' or 'against', we will end
up with a lot of text but little action. Please move any such debates to forums
or mailing lists.
To progress this Issue, please see my original points: we need to run a poll to
get a democratic decision. The resolution I prefer is to add an IFDEF to include
or exclude all EE when OOo is built. For environments that require EE removal
(school, etc.), a special build can then be generated (I suspect customized
builds would be desired anyway). In the default builds EE might (or might not)
be enabled depending on how people vote.
Having started to investigate some of the code and resources, the extra size is
probably less than 2MB. It would be good if a Developer could check this and
report on all EE that exist in OOo currently.

Regards,
Andrew
Comment 15 Olaf Felka 2006-02-09 10:42:28 UTC
Please don't offer different builds! One with and one without EEs!? This will
duplicate e.g the QA efford. Every build has to be tested twice. We need a
decision: EEs or not. I like them and I would like to keep them. But this can't
be voted. So voting here is meaningless.
Comment 16 pmike 2006-02-09 10:48:50 UTC
If voting is meaningless, then it's better to remove EE.
*But* provide them as downloadable "extension".
Comment 17 ace_dent 2006-02-09 11:05:45 UTC
To clarify...
@'of', I'm not suggesting that OOo offers different builds, just that a switch
exists to remove the EEs for people who make their own custom builds. As such,
someone's custom OOo build would fall outside 'warranty' for EE issues
(obviously!), but since these EEs are meant to be nice'n'safe and
self-contained, then surely removing them would have no effect on OOo
stability...? But if we reached a decision by a large majority, then just one
build is appropriate.
Voting on this Issue obviously can't reflect those against, but I proposed that
a Poll is run on a forum, to quantify: Yes, No, Don't care. Maybe someone with
some spare time could set this up at oooforum.org, without bias.

@'pmike', a downloadable extension would defeat the point of an EE and also
require more OOo developer effort. Ideally we are looking for the least effort
possible.

Regards,
Andrew
Comment 18 jcausey 2006-02-09 22:05:05 UTC
Just some additional comments on the perception of EE's.

Here, http://www.networkworld.com/newsletters/sec/0327sec1.html , an older
article about security.  Notice this part:

"How much space in the source and object code does this Easter egg take? How
much RAM and disk space are being wasted by all the people who have installed
and are using this product? And much more seriously, what does this Easter egg
imply about the quality assurance at the manufacturer's offices?

An Easter egg is presumably undocumented code - or at least, it's undocumented
for the users. ...I think the failure implies that there is no test-coverage
monitoring in that quality assurance process."

In the article, the author is talking about MS products.  Do we really want OOo
to be substituted and the target of analysis like this?

Here, http://www.soci.niu.edu/~rslade/secgloss.htm , we have a glossary of among
other things, information security terms.  Here is part of what is said about EE's:

"Opinion regarding easter eggs varies, from those who see them as simply
harmless jokes to those who consider the more complex inclusions to be trojan
horses. In general, however, the practice of including easter eggs and other
undocumented code in programs is detrimental to strict security."

By continuing to include the EE's, OOo may be practicing something that is
considered "detrimental to strict security".  Is that the message we want
potential users to get?

Finally, here http://www.newsforge.com/article.pl?sid=05/12/01/161213 we have a
parody that was written just this past December about aliens (real aliens, like
little green men from space) inserting malicious code into OSS projects like
Linux.  The thing about writing something like this is that it must contain
little gems of truth to it and introduce concepts that are silly.  Down near the
end we find this:

"As mentioned above, Windows is far too secure to be compromised by an alien.
Not only that -- and this is the important part -- there is no way for that
alien to hide code within Windows itself, while it could easily become a Linux
kernel contributor and slip its nefarious Easter eggs into Linux."

Why is that funny?  Obviously because there is a belief that, thanks to the OSS
programming method, the presence of Easter eggs in Linux is ridiculous.  And it
is probably equally ridiculous for other major OSS apps (which I think OOo is
one).  Yet here we are with EE's included in the code.

While I appreciate the position of the programmers and others who don't mind the
EE's, I fear there is far more of a downside to including them than there is an
upside.  Yes, the downside may be based a lot on perceptions.  Unfortunately, it
is far too common in this day and age that perceptions = reality.  And as we try
to push for wider adoption of OOo, this is one perception that we should not
have to battle if it can be corrected.

Once again, thanks for your consideration!

Jeff Causey
Comment 19 cno 2006-02-09 23:53:15 UTC
IM(nsv)HO:
- thinking EE's have any relevant infulence on used diskspace/memory is a sign
of misunderstanding of the real code base of OOo.
- EE's have nothing to do with security, being trusthworthy of code, quality
control or whatsoever. Malicious code could be made in many ways, by purpose or
not. An author putting EE and malicious code at one line, just doesn't
understand. Thinking that software is more secure because no EE are present, is
just not rational.
- EE's never came up as possible issue in my professional/business contacts
(office software).
- for our school going children, there are many (possible) threats on the
computer/internet, that have nothing to do with EE's. 
- there's not at all an argumented obvious contra EE's outcome, in Larry
Osterman's weblog.

EE's are not a culprit, nor a danger, above all no vehicles for Trojan Horses
(it's open source software: 'look, threre they are' :-)  just some fun, a
harmless privilege for the coders.

If we consider this, I would advice that we leave the developers (and ourselves)
with the more important issues.


Comment 20 ace_dent 2006-02-10 00:25:33 UTC
To move this forwards I have created a Poll here:
http://www.oooforum.org/forum/viewtopic.phtml?t=31663

Please add your personal views and votes there.

Many thanks,
Andrew
Comment 21 Regina Henschel 2010-12-31 00:20:24 UTC
I think, this request as become obsolete, because in OOo3.3 all Easter Eggs are
removed. See issue 111231.
Comment 22 Regina Henschel 2015-03-12 22:08:55 UTC
All easter eggs are removed.