Issue 62201

Summary: OOo crashes using base form
Product: Base Reporter: Mechtilde <mechtilde>
Component: codeAssignee: marc.neumann
Status: CLOSED IRREPRODUCIBLE QA Contact: issues@dba <issues>
Severity: Trivial    
Priority: P2 CC: andre.schnabel, issues, pavel
Version: OOo 2.0.2Keywords: regression
Target Milestone: OOo 2.0.3   
Hardware: PC   
OS: Linux, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on: 62088    
Issue Blocks:    
Attachments:
Description Flags
Database which contain the formular none

Description Mechtilde 2006-02-17 12:35:53 UTC
I use the RC1 of 2.0.2

I want to use a form which I use since Jun05 in all dev-versions.
It works till 2.0.1 but not in RC1 of 2.0.2
So it is a regression.

Here step by step
1. Open the base modul
2. Open the *.odb file
3. Open the form
4. Enter the key for the MySQl-DB. The form opens.
5. a) If you try to navigate to the last tupel using the navigation buttons, OOo
crashes
   b) If you navigate with the arrow keys you can reach the last tupel but you
cant insert new entries. If you you go to a new tupel OOo freezes.

For me it's a showstopper.

5.
Comment 1 Frank Schönheit 2006-02-17 12:56:19 UTC
could you attach the database in question plus the script to generate the MySQL
table/structure?
Comment 2 Mechtilde 2006-02-17 13:10:49 UTC
Created attachment 34242 [details]
Database which contain the formular
Comment 3 Mechtilde 2006-02-17 13:14:07 UTC
here is the link to the mysql dump

http://www.openoffice.org/nonav/issues/showattachment.cgi/33209/Hauptbuchdump

If you use it wih the Hauptbuch2006.odb you must input some datas in three tables.

The form Uberweisung is the one which doesn't work.
Comment 4 Mechtilde 2006-02-17 15:24:59 UTC
I can confirm it after further tests.
Comment 5 Joost Andrae 2006-02-17 15:36:48 UTC
JA: changed priority
Comment 6 marc.neumann 2006-02-20 11:32:40 UTC
Hi,

I can't reproduce this. I have no problem to travel through the records in the
form. I have tested OOo and So . The ODBC driver version 3.51.11 and 3.51.12.

Bye Marc
Comment 7 Mechtilde 2006-02-21 07:07:18 UTC
In RC2 I can confirm 5 b 

so you can navigate to the last tupel but can't enter a new tupel

Comment 8 Mechtilde 2006-02-21 14:54:37 UTC
Does it depend on 51116
Comment 9 Martin Hollmichel 2006-02-21 17:45:59 UTC
we still have problems to reproduce this in such way, that a developer can work
of this. for this reason I suggest to set the target to 2.0.3. so we don't risk
the release date of 2.0.2 for an issue which doesn't affect majority of users.
But we need to work on this with high priority since this is an regression and
users are obviously affected.
Comment 10 Frank Schönheit 2006-02-22 11:31:44 UTC
mechthilde, does any of the two libraries from
http://dba.openoffice.org/servlets/ProjectDocumentList?folderID=547&expandFolder=547&folderID=0
prevent your crash?
Try putting them into your <installation>/program directory (after backing up
the existing version), and re-run your scenario. Start with the first version,
and if this crashs, try the second one. Would be interested in the results.
Comment 11 Mechtilde 2006-02-22 19:00:21 UTC
both versions crashed

I sent the crash report
the first one at 19:48
the second one 19:56
Comment 12 Mechtilde 2006-02-27 15:22:20 UTC
I test both version which Frank attached on this issue also with the RC5 but
both version and the original version chrashed.

So nobody who works with the base modul may update to 2.0.2
Comment 13 p9w.vu.31122010 2006-02-27 16:55:44 UTC
I cannot reproduce this either.
Navigating through the table with the navigation buttons works flawlessly.
Comment 14 Mechtilde 2006-03-02 09:53:36 UTC
After discussion with SimonAW and cloph I run

export SAL_USE_VCLPLUGIN=gtk

so after a new start of OOo it does not crash.
The surface has changed.
If I set  export SAL_USE_VCLPLUGIN=gen it does not crash also and the surface
was the old one.
the same thing I saw after unset SAL_USE_VCLPLUGIN

So it works for me.

But I see there a new problem: to enter new tupels need a special way thats not
good and different from 2.0.1. But this is something for a new issue.

Comment 15 Mechtilde 2006-03-25 16:59:42 UTC
mechtilde: Could not reproduce the last mentioned problem, please ignore.
Comment 16 marc.neumann 2006-03-27 09:07:54 UTC
Hi,

So can we close this issue now?

Bye Marc
Comment 17 Mechtilde 2006-03-29 11:27:13 UTC
the new issue is #63476

so this issue can be closed