Issue 62364

Summary: Stacked Bars charts : bars are (also) not really stacked
Product: General Reporter: greenslach <greenslach>
Component: chartAssignee: IngridvdM
Status: CLOSED DUPLICATE QA Contact: issues@graphics <issues>
Severity: Trivial    
Priority: P4 CC: issues
Version: 3.3.0 or older (OOo)   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: FEATURE Latest Confirmation in: ---
Developer Difficulty: ---

Description greenslach 2006-02-21 01:29:51 UTC
In this spreadsheet :
http://www.openoffice.org/nonav/issues/showattachment.cgi/3572/9184-BadStackedChart.sxc

In Column C3, the yellow bar should go from -17 to 1 and not from 0 to 18. 
There is a similar problem in column C5.
Comment 1 kla 2006-02-21 10:24:52 UTC
@IHA: I think the behaviour is correct. Maybe an idea for an new Charttype?
Comment 2 IngridvdM 2006-02-21 13:25:03 UTC
The current behaviour is as designed. Negative bars are stacked below and
positive bars are stacked on top, thus the length of all bars are visible. This
issue is requesting a different behaviour that maybe can be introduced by a
parameter for bar charts or by introducing a completly new charttype. I am not
sure about that yet. It is also not clear to me why you want the bars to be
summed up independent from their sign. This will only lead to bars hiding each
other. Maybe choosing the area or line chart does fit your needs much better and
will do the trick for you?
Comment 3 greenslach 2006-02-23 14:14:59 UTC
I reported this issue because the current behaviour seemed unexpected to me.  I
agree there isn't much practical uses for negative stacked bars.

I just see one case where it would be useful : building a Gantt chart using
stacked bars, where you have a task planned to start a fixed number of days
before the end of another task.

Comment 4 IngridvdM 2006-03-07 12:50:42 UTC
As the Gantt chart is targeted already with issue 10704 I close this issue as
duplicate.

*** This issue has been marked as a duplicate of 10704 ***
Comment 5 IngridvdM 2006-03-17 13:09:08 UTC
closed