Issue 63127

Summary: Currency number format in table reverted to text format on change of content
Product: Writer Reporter: joerg.skottke
Component: formattingAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: gero, issues
Version: OOo 1.0.3   
Target Milestone: ---   
Hardware: All   
OS: Windows, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description joerg.skottke 2006-03-13 16:58:09 UTC
A customer on CeBIT reported that table formats (writer-tables) lose their
format when edited.

Example:
- create a table
- enter some numbers, align them vertically to anything != default
- select one of the fields, edit it
-> The format is lost.
Comment 1 michael.ruess 2006-03-14 16:46:17 UTC
I cannot reproduce the problem. Please explain what you mean by "select one of
the fields, edit it".
Is the option "Number recognition" enabled or not?
Comment 2 michael.ruess 2006-03-16 09:37:33 UTC
Reopened for new state.
Comment 3 michael.ruess 2006-03-16 09:40:24 UTC
The described issue happens with the currency format.
MRU->OS: it is already listed in issue 46076, bit that one is a "collective
task" having two issues in it. Also I think, that this is a bug.
when having a currency format content in a table cell, it is reverted to
text-format when the cell content is changed. This is highly unexpected here.
Comment 4 Oliver Specht 2006-06-20 14:19:15 UTC
Target adjusted
Comment 5 Martin Hollmichel 2007-09-10 13:36:05 UTC
move target to 3.x according http://wiki.services.openoffice.org/wiki/Target_3x
Comment 6 oreg 2007-09-14 21:09:26 UTC
This is a duplicate of bug #54397 (or vice versa).
Comment 7 Oliver Specht 2007-09-18 09:00:43 UTC
->oreg: This is not a duplicate of 54397 because it is about changed alignments
and not changed number formats.
Comment 8 oreg 2007-09-18 15:19:28 UTC
os: I should have been more clear on this. Both bugs are about cells with a
number format switching back to text format when edited. The problem shows,
among other characteristics, by the alignment switching from right to left. Also
refer to the summary of both bugs.

Bottom line: These bugs describe exactly the same problem.
Comment 9 Marcus 2017-05-20 11:18:05 UTC
Reset assigne to the default "issues@openoffice.apache.org".