Issue 64913

Summary: Find&Replace of trigger file exhausts 2GB VM and crashes OO
Product: Writer Reporter: filipg <filipg>
Component: programmingAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P4 CC: issues
Version: 680m164   
Target Milestone: ---   
Hardware: PC   
OS: Windows 2000   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on: 17171    
Issue Blocks:    
Attachments:
Description Flags
Screenshot along a crash & how to recreate
none
the trigger file - 3 columns, a bit over 80K characters
none
Shot of post-crash VM report none

Description filipg 2006-04-30 02:42:29 UTC
This issue exhausts all memory, sucks up all VM, and then tries to connect to a
parallel universe for more memory... er, it crashes OO.

It does this on 2.0.2 stable, m158, and m164 under Win2KSP4 & WinXPSP2
so I'm pretty sure I'm not 'seeing things' :-)

I do NOT think this is in any way related to issue 50510.
I attached:
* ODT file describing the issue (screenshots) & how to recreate
* OO - trigger.odt which does the deed
* a screen shot from the office machine (running 2.0.2 stable) showing the
peak VM usage (also see graph).

Cheers,
Fil
Comment 1 filipg 2006-04-30 02:43:07 UTC
Created attachment 36156 [details]
Screenshot along a crash & how to recreate
Comment 2 filipg 2006-04-30 02:43:42 UTC
Created attachment 36157 [details]
the trigger file - 3 columns, a bit over 80K characters
Comment 3 filipg 2006-04-30 02:44:11 UTC
Created attachment 36158 [details]
Shot of post-crash VM report
Comment 4 filipg 2006-04-30 02:46:43 UTC
BTW, I did let OO send its own crash report before posting this. I clicked 'SUN
can contact me'...
Comment 5 michael.ruess 2006-05-02 08:14:09 UTC
Reassigned to SBA.
Comment 6 jack.warchold 2006-05-05 15:13:00 UTC
confirmed on src680_m165
the application consumes a lot of memory and than after some minutes, 10 
minutes in my case, crashes.

cpu activity was arrount 5% on this time.

reassigned to jw to find the proper developer for this.

set default target
Comment 7 jack.warchold 2006-05-08 12:50:26 UTC
could not create a file by my own on which this happens, because of this i set the 
prio to p4

reassigned to os
Comment 8 filipg 2006-05-14 20:52:55 UTC
I will try to make instructions to recreate trigger file. This problem may be
related to the 64KB limit on any one line - the file is ONE long line!
Comment 9 filipg 2006-05-15 00:13:44 UTC
In fact, I bet that this issue is related to the 64K paragraph limit. Here's
what I found in a newsgroup:

"Be careful with replacing $ by another token. Better yet, avoid doing that.
Replacing the paragraph mark by something else implies that temporarily, you
create a very long paragraph. Writer will happily and without warning truncate
all paragaph text that exceeds 64 K. Yes, there is a 64 K paragraph limit in
Writer. This issue is known to the developpers."

I know that m167 will NOT let me create a paragraph bigger than 64KB so this
might be related to this. I did NOT know this when I wrote that file!

Comment 10 filipg 2006-05-15 01:32:43 UTC
The 64KB per paragraph limit is issue 23897.
Comment 11 filipg 2006-05-15 01:37:32 UTC
Drat. Make that issue 17171 (the other one is a closed duplicate).

I will make you directions for making a trigger file in any case. Give me a day
or two. Thanks.
Comment 12 Marcus 2017-05-20 11:24:29 UTC
Reset assigne to the default "issues@openoffice.apache.org".
Comment 13 Marcus 2017-05-20 11:26:07 UTC
Reset assigne to the default "issues@openoffice.apache.org".