Issue 65325

Summary: Don't talk about sending crash report when it's disabled
Product: Draw Reporter: kendy
Component: codeAssignee: thorsten.martens
Status: CLOSED FIXED QA Contact: issues@graphics <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: 680m167   
Target Milestone: OOo 2.x   
Hardware: All   
OS: All   
Issue Type: PATCH Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 68352    
Attachments:
Description Flags
The fix.
none
Localization - if that's of some value. none

Description kendy 2006-05-12 12:49:20 UTC
From our bugzilla: 
 
----- 8< ----- 
Because of this, I've been seeing the document recovery screen pretty regularly 
upon (re-)start up of OO 2. 
 
On that screen, it says, "Click 'Next' to get to the Error Report Tool..." yet 
there is no "Next" button, so I can't get to the report.  It might be stored on 
my hard drive somewhere and I can provide any that I might still have around to 
help with  Bug 164897 if someone can tell me where to look. 
----- 8< ----- 
 
But in fact, we have disabled the crash reporter in our builds by storing 
'false' into the CrashReporter::Enabled in Recovery.xcs.  I'll attach a patch 
that fixes that - lets OOo not to talk about crash reporter when it's disabled.
Comment 1 kendy 2006-05-12 12:50:10 UTC
Created attachment 36421 [details]
The fix.
Comment 2 kendy 2006-05-12 12:50:48 UTC
Created attachment 36422 [details]
Localization - if that's of some value.
Comment 3 ooo 2006-05-17 10:23:30 UTC
reassigned to HRO
Comment 4 kendy 2006-06-12 08:47:42 UTC
hro: Ping? ;-)
Comment 5 hennes.rohling 2006-06-12 09:27:04 UTC
.
Comment 6 kendy 2006-07-12 11:54:50 UTC
hro: This is really a trivial one - can you have a look, please?  It involves 
translation changes and the deadline of 2.0.4 is quite close...

I can do all the CWS stuff, etc.
Comment 7 kai.sommerfeld 2006-10-19 15:07:27 UTC
Andreas, document recovery is your resort. Please take over.
Comment 8 Mathias_Bauer 2006-10-20 09:14:55 UTC
Thanks for the patch, Andreas will have a look when he's back from vacation
Comment 9 andreas.schluens 2006-11-03 10:42:49 UTC
.
Comment 10 andreas.schluens 2006-11-03 12:28:48 UTC
The patch seams to be acceptable. But we have to update the specification 
acoordingly. I will do that. Please stay tuned ....
Comment 11 andreas.schluens 2006-11-17 13:00:36 UTC
AS->kendy: I've used the idea behind the patch  ... but not the patch itself.
Reason: you changed the text of the first dialog page without any reason.
Because there nobody is talking about error reports etcpp. Further the last
dialog page was updated in case the error report is enabled ... but you forgot
to update the description text in case error report is disabled .-)

Anyway: I've changed the spec; our user experience team accepted it; I've made
all source code changes. Next time you will have AutoRecovery without an
ErrorReport realy.
Comment 12 kendy 2006-11-20 10:39:53 UTC
as: Thanks! :-)  In what CWS is it now, please?
Comment 13 andreas.schluens 2006-11-20 10:47:11 UTC
The cws is "patch01as".
The link to the changed spec is
"http://specs.openoffice.org/appwide/errorreporter/error_report_2_0_ui_specification.odt".
Comment 14 kendy 2006-11-20 10:48:35 UTC
as: (That's because I'd like to check "Because there nobody is talking about 
error reports etc." - I see "A report of the crash was created helping us to 
identify the cause why %PRODUCTNAME crashed. Click 'Next' to get to the Error 
Report Tool or press 'Cancel' to skip this step." in the current sources & 
nothing like that will be displayed with the crash reporter disabled.)
Comment 15 kendy 2006-11-20 10:57:43 UTC
as: Looks great in the CWS, thank you again!
Comment 16 andreas.schluens 2006-12-06 10:37:02 UTC
AS->TM: Please verify this task on the cws [patch01as]. THX.
(Note: Spec on specs.openoffice.org was changed accordingly).
Comment 17 thorsten.martens 2006-12-11 13:14:18 UTC
checked and verified in cws "patch01as" -> OK !
Comment 18 thorsten.martens 2007-02-12 15:28:33 UTC
closed