Issue 65651

Summary: Anchor position of drawing elements changes when reopen .xls created from .ods
Product: Calc Reporter: Rainer Bielefeld <rainerbielefeld_ooo_qa>
Component: save-exportAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P4 CC: issues
Version: OOo 2.0.2   
Target Milestone: ---   
Hardware: PC   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
test kit showing misplaced anchors in reopened .xls none

Description Rainer Bielefeld 2006-05-21 09:18:55 UTC
I checked with "2.0.2  German version WIN XP: [680m5(Build9011)]" and saw that
the anchor position for images changes, if I save the document as .xls, but not
in the same way for all kinds of images.

Steps to reproduce:

1. Open new spreadsheet.
2. Insert some flowchart symbols to column B as you see in 
   attachment 'mytestforsaveas.ods'  
3. Enter a rectangle to column B
4. Enter a symbol shape to column b
5. check anchor using context menu: should be "to cell"
5. Click all images one by one with pressed shift key, 
   you should see all anchors in column B (as shown in screenshot image in
   'mytestforsaveas.ods'.
6. save file as .ods
7. save file as .xls
8. test as in step 5, 
   you should see same result.
9. close file
10. reopen .xls file
11. repeat test as in step 5, 
    expected: same result for anchors as in step 5 and 8
    actual: All anchors except for "symbol shape" now are in column A

This issue might be related to issue 65564
Comment 1 Rainer Bielefeld 2006-05-21 09:35:55 UTC
I can not see that "anchor hike problem" vor .xls documents created with 1.1.4 
I created a .xls with some rectangles, ellipses in column B using 1.1.4, saved
it as .xls and reopened the .xls with 2.0.2. In that file all anchors still were
at their place in column B. That seems to say that it's an OOo 2.0.2 save-export
problem. 
Comment 2 Rainer Bielefeld 2006-05-21 09:39:50 UTC
Created attachment 36629 [details]
test kit showing misplaced anchors in reopened .xls
Comment 3 Rainer Bielefeld 2006-05-21 09:43:05 UTC
More meaningful summary
Comment 4 frank 2006-07-07 14:30:17 UTC
Hi Daniel,

please have a look and proceed as needed.

I think it's a problem with the position to close to the borders of the cell so
the different measurement systems between Calc and Excel causes this, am I right ?

Frank