Issue 65775

Summary: update mozilla bootstrap stuff for a recent mozilla API
Product: Base Reporter: pmladek <pmladek>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, mozilla, rene
Version: OOo 2.0.2   
Target Milestone: ---   
Hardware: PC   
OS: Linux, all   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description pmladek 2006-05-25 13:18:27 UTC
The mozilla bootstrap stuff in connectivity/source/drivers/mozab/bootstrap uses
an old mozilla API, so it is not easy to compile it against recent sources,
preferably against Gecko SDK.

Would be possible to update it for the new API or are there many other problems?
Comment 1 Frank Schönheit 2006-05-29 11:04:56 UTC
The driver can be compiled against Mozilla sources present in the system, and
against a patched Mozilla 1.7.x. For parts of the functionality, the patches are
essential.

So while I'm absolutely open to changing the bootstrap code to a more recent
API, this needs to happen relative to the 1.7.x branch. Alternatively, we could
move to a lter release, too, but that's a different story which I did not yet
find time to embark on. And probably, I won't find this time, soon ....
Comment 2 Frank Schönheit 2006-10-12 10:02:15 UTC
targeting
Comment 3 Frank Schönheit 2008-11-05 13:55:44 UTC
for the record: Ongoing work in CWS moz2seamonkey01 will update the Mozilla
sources to SeaMonkey 1.1.12 - which is certainly not the most recent one, but
better than nothing, hopefully ...
Comment 4 Marcus 2017-05-20 10:47:31 UTC
Reset assigne to the default "issues@openoffice.apache.org".