Issue 65799

Summary: impossible to set cursor by mouse-click left of objects that are anchored as character
Product: Writer Reporter: norbert2 <norbert.notz>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, mjcervan, rainerbielefeld_ooo_qa
Version: OOo 2.0.2   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: 4.1.0-dev
Developer Difficulty: ---
Attachments:
Description Flags
cursor.odt
none
cursor2 none

Description norbert2 2006-05-26 20:55:17 UTC
hi,

please open the attached document.

normally it is possible to click left in front of a line (outside of the content
area) to set the cursor to the beginning of the line.

this works fine for the first line of the document.

But in line 2 and 3 that begin with a picture / formula (anchored as character)
this does not work. In this case the cursor is set right after the object.
Comment 1 norbert2 2006-05-26 20:55:44 UTC
Created attachment 36739 [details]
cursor.odt
Comment 2 norbert2 2006-05-26 20:57:16 UTC
(please correct the summary "bevore"->"left in front of".)
Comment 3 michael.ruess 2006-05-29 14:01:27 UTC
MRU->FME: it is only possible to get left of the objects by moving with cursor keys.
Comment 4 norbert2 2006-05-29 17:46:49 UTC
additional info:

this problems only exists for left aligned lines and the left side.
(clicking right on right aligned lines places the cursor as ecpected.)
Comment 5 frank.meies 2006-06-23 16:13:00 UTC
FME: Considering the resources and the effort, I have to set the target to "OOo
later"
Comment 6 norbert2 2007-02-07 16:51:15 UTC
Please open the attached document "cursor2".

Try to select the whole document using the mouse. It is impossible to include
the picture to the selection!
Comment 7 norbert2 2007-02-07 16:51:53 UTC
Created attachment 42833 [details]
cursor2
Comment 8 Regina Henschel 2012-10-23 18:10:34 UTC
*** Issue 121252 has been marked as a duplicate of this issue. ***
Comment 9 Rainer Bielefeld 2014-02-18 06:50:00 UTC
Still Reproducible with server installation of "AOO 4.1.0-Dev – English UI / German locale - [AOO410m1(Build:9750) - Rev. 1566800 - 2014-02-12]" on German WIN7 Home Premium (64bit)", own separate user profile.