Issue 66887

Summary: Undo converts multiple cells selection in a table to multi-text selection
Product: Writer Reporter: raindrops <na1000>
Component: editingAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 2.0.3   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Describes the problem in moving contents of multiple cells none

Description raindrops 2006-06-30 10:38:33 UTC
Note: This is about version m173.

See the attached file which contains a small table. 

1. Select text in the range C5:D6.
2. Now move it (drag-n-drop) into cell C1. The text gets moved to range C1:D2.
This is the correct behavior.
3. Now press CTRL+Z to undo step-2.
4. Select the text again and move it to cell B2. 
All the cells' content is now combined into cell B2. (Defect)

Apart from B2, there are several cells in the table that behave like this.
Comment 1 raindrops 2006-06-30 10:40:49 UTC
Created attachment 37440 [details]
Describes the problem in moving contents of multiple cells
Comment 2 michael.ruess 2006-07-17 15:54:48 UTC
I cannot reproduce the problem. It also looks good when I drag the selected
cells into cell B2.
Could you add a screenshot how it looks after you dragged the cells into Cell B2?
Note: after doing Ctrl-Z in Step 3 you do NOT have a cell selection anymore; it
is a multi-selection of text. Could it be that this has confused you?
Comment 3 raindrops 2006-07-17 17:22:08 UTC
Well, you seem to be right: When I did the selection afresh, the document
behaved notrmally. Only when did the CTRL+Z, did it misbehave.

But that's how I sensed the bug in the first place: I expected a "CTRL+Z" to
just reverse the last movement of multiple cells. Instead, it ALSO changes the
multi-cell selection into multi-text selection. Now THAT is a bug. (It should
not be closed as WorksForMe, because that's not the expected behavior of Writer,
either!)

I have changed the summary to reflect the bug as I understand now.
Comment 4 michael.ruess 2006-07-18 10:34:23 UTC
MRU->HBR: When performing an undo e.g. on merging or dragging table cells, not
the cells but only the text inside the cells is selected after this. It should
remain a cell selection.
Comment 5 openoffice 2008-11-24 15:06:41 UTC
ama took over undo