Issue 67780

Summary: undoing endnote insert doesn't restore insert->header state
Product: Writer Reporter: caolanm
Component: codeAssignee: michael.ruess
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 2.0.3   
Target Milestone: ---   
Hardware: All   
OS: Linux, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description caolanm 2006-07-26 10:16:52 UTC
1. Insert -> Footnote -> select 'Endnote' and click Ok
2. Edit -> Undo: Insert footnote
But "Endnote" is now listed from "Insert -> Header/Footer"
e.g. 
3. Insert -> Header/Footer -> select 'Endnote'
nothing appears to happen.

Perhaps when we have undone an endnote insertion that restores the endnote count
to 0 we can revert the insert->header/footer back to the original pre-endnote
insertion state ?
Comment 1 michael.ruess 2006-07-26 13:30:21 UTC
Problem is more general.
In menu Insert.Header the submenu lists the currently used page styles. These
will not be removed from the submenu if not in use anymore (e.g. by Undo or
assigning different style).
Will be completely reworked; see issue 60426.

*** This issue has been marked as a duplicate of 60426 ***
Comment 2 michael.ruess 2006-07-26 13:31:49 UTC
Closed.