Issue 6889

Summary: pdf creation posible with OOo ?
Product: General Reporter: lars <lars_o_hansen>
Component: codeAssignee: falko.tesch
Status: CLOSED FIXED QA Contact: issues@framework <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 1.1 RC   
Target Milestone: OOo 1.1   
Hardware: All   
OS: All   
Issue Type: FEATURE Latest Confirmation in: ---
Developer Difficulty: ---

Description lars 2002-08-09 16:38:53 UTC
i thought I read it on openoffice.org somewehre when 1.0.0 was released.

Is it possible in OOo without installing a particular printer driver or other 
programs to create color (Adobe standard) pdf files?

If not and if it is not too demanding and license issues are in the way, please 
implement it, because the Adobe PS 3 driver creates PS files, GsView via 
ghostScript doesn't translate into color pdf files which with gsview look like 
the OOo original (or was it the adobe ps3 ps file which already didn't 
look "correct" in GsView and I didn#t get it to look corect, no matter the 
driver option?)
Comment 1 thorsten.martens 2002-08-12 10:28:37 UTC
TM->FT: A new wish for a feature, please have a look, thanks !
Comment 2 thegoldenear 2002-08-14 08:06:19 UTC
this looks like a duplicate of issue 5168
Comment 3 lars 2002-08-14 11:59:07 UTC
I like to have direct PDF file creation ('save as') and no additional 
programs or PDF creation through print dialogue.

If the mentioned "interface" from issue 5168 is moved to the save as 
dialogue and GhostScript is still needed, it will still be OK if 
GhostScript produces PDF files which are always identical to the OOo 
original.


But as Adobe sells its Acrobat PDF creator for 250$ I doubt it 
is "possible" to implement pdf creation in OOo.
Comment 4 lars 2002-08-19 22:04:11 UTC
It was my issue, but I have no need for it anymore. Can I close it as 
wontfix?

See issue  'Seperate content creation and content viewing'


As OOo formats should be used wide-spreadly, there is no need of 
course for PDF.


this issue is in the ring of issues concerning this matter: issue 
7137 'Seperate content creation and content viewing', issue 
7138 'write-protection on document-level', issue 6889 'pdf creation 
posible with OOo ?'
Comment 5 horkana 2002-09-04 21:09:48 UTC
> but I have no need for it anymore

close it as invalid

it is probably more important just to close this than how you close it.  
Comment 6 Unknown 2003-01-09 15:23:06 UTC
It is in 643c. I can only assume that the next stable release will
also have it in. Hope this helps.
Comment 7 chris 2003-03-07 14:34:46 UTC
Let's close as a duplicate of the first report.

*** This issue has been marked as a duplicate of 2660 ***
Comment 8 michael.bemmer 2003-03-11 17:32:05 UTC
As mentioned on the qa dev list on March 5th I will close all resolved duplicate
issues. Please see this posting for details. First step in IssueZilla is
unfortunately to set them to verified.
Comment 9 michael.bemmer 2003-03-11 18:01:14 UTC
As mentioned on the qa dev list on March 5th I will close all resolved duplicate
issues. Please see this posting for details. 
Comment 10 michael.bemmer 2003-03-11 18:01:25 UTC
As mentioned on the qa dev list on March 5th I will close all resolved duplicate
issues. Please see this posting for details. 
Comment 11 lars 2003-07-22 16:19:40 UTC
Yes it is possible now and it's very good!  :-)


congratulations for such a good implementation!  the pdfs created 
from Writer files look excellent and they are identical to the Writer 
files (no layout-errors or such)!
Comment 12 lars 2003-07-22 16:20:09 UTC
yes
Comment 13 lars 2003-07-22 16:21:10 UTC
close if available with OOo 1.1 final release.
Comment 14 Olaf Felka 2003-07-23 09:08:03 UTC
"close if available with OOo 1.1 final release." Why? Why not closing
now? We have it now and we won't kick it out for final!