Issue 68963

Summary: File 'open' / 'save as' function does not open directory links.
Product: General Reporter: waymonc <waymonc>
Component: uiAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, rainerbielefeld_ooo_qa
Version: OOo 2.0.3Keywords: oooqa
Target Milestone: AOO Later   
Hardware: PC   
OS: Windows XP   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description waymonc 2006-08-25 19:54:17 UTC
When saving a file the 'save as' function selects a directory link as the 
filname rather than navigating through the link to the directory where the link 
Comment 1 Rainer Bielefeld 2006-08-26 18:48:56 UTC
I'm sorry, but I don't understand your problem. 
Please first read our guidelines on
<> and  
<>, then
contribute a clear step by step instruction containing every key press and every
mouse click how to reproduce the problem.

Do you really only see that problem with WRITER or also CALC?
Comment 2 michael.ruess 2006-08-29 08:10:00 UTC
Framework issue.
Comment 3 waymonc 2006-08-29 19:30:43 UTC
A link is a pointer to a file or directory, or in windows parlance, a shortcut.
Create a shortcut that points to a directory and try to use the OpenOffice 
navigation box to get to a sub subdirectory under that link (shortcut).
That's where it doesn't work.

For example create a shortcut in the My Documents directory that points to the 
Shared Documents directory. Then try to navigate to a sub-directory in the 
Shared Documents directory through the link.
That's where it doesn't work.
Hope that helps.
Comment 4 Rainer Bielefeld 2006-08-31 14:31:42 UTC
No, unfortunately your comment was not helpful, because you did not heed the
hints in the guidelines and my requests.

I tried to find about what the report might be and did a test as following with
"2.0.2  German version WIN XP: [680m5(Build9011)]". 
waymonc, pls. tell us whether that is the problem you wanted to report.

1. Open WIN EXPLORER for "My Documents" or similar
2. rightclick - NEW - Link
3. search for an existing OOo file 
4. Create Link with name "Test1" and finish
5. rightclick - NEW - Link
6. search for an existing OOo file like in step 3
7. delete filename from complete link, so that only '...\somedirectory\'
   remains - so you get a link to a directory
8.  Create Link with name "Test2" and finish 

9. Test link "Test1" by doubleclick in WIN explorer
   as expected, the OOo document will be opened
10. Test link "Test2" by doubleclick in WIN explorer
   as expected, EXPLORER window changes to directory that contains the 
   OOo document
11. Start OOo
12. Menu "Tools - - General"
    Uncheck "Use OOo-Dialogues", if it is checked
13. Close dialogue
14. Menu "File Open"
15. Change to folder "My Documents" from Step 1
16. Doubleclick Link "Test1"
    expected: the linked OOo document should be opened
    actual: as expected.
17. Menu "File Open"
18. Change to folder "My Documents" from Step 1
19.  Doubleclick Link "Test2"
20.  expected: EXPLORER window should change to linked folder
     actual: as expected.
21. Menu "Tools - - General"
    CHECK "Use OOo-Dialogues"
22. REDO starting with step 13
    Expected: all should work as with WIN dialogues
    Actual: "Test1" will open the dialogue for "Coded Text"
            "Test2" will open the dialogue for "Coded Text"

Comment 5 Rainer Bielefeld 2006-08-31 15:01:47 UTC
You have a similar effect for "save as":
"Test2" will lead to the directory only if "use OOo dialogues" is unchecked.
Comment 6 Rainer Bielefeld 2006-09-13 08:52:58 UTC
Due to "Additional comments from rainerbielefeld Thu Aug 31 06:31:42 -0700 2006"
with amended subject and because of  Issue 55843
Comment 7 Rainer Bielefeld 2006-09-15 17:10:13 UTC
*** Issue 55843 has been marked as a duplicate of this issue. ***
Comment 8 thorsten.martens 2006-10-16 10:38:26 UTC
TM->requirements: OOo´s own file-dialogs don´t have the ability to open/follow
up links. So this issue is not a defect because the problem describes a missing
feature. So I set this one to "enhancement".
Comment 9 waymonc 2006-10-16 22:45:59 UTC
How do I sign off on this issue (using the windows dialogs worked)?