Issue 68967

Summary: Find backward with format and "search for" found only in current paragraph (in writer)
Product: Writer Reporter: tombil <tombil>
Component: editingAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, rainerbielefeld_ooo_qa
Version: OOo 2.0.3Keywords: oooqa
Target Milestone: ---   
Hardware: PC   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
document demonstrates the problem
none
search for T specifying T as in italics and check backwards option in the search dialogue box none

Description tombil 2006-08-25 23:42:22 UTC
Reproduce Steps:
1. New document, create 3 the same paragraphs containing e.g. "word",
   set to italic.
2. Move cursor to end of 3th paragraph (end of document).
3. Find/Replace with: Search for - "o", Backward, Format/Italic.
4. After click "Find" is found "o" inside 3 th paragraph, it is ok.
5. After next click to "Find" OOo report "Not found...", instead of found
   "o" in 2th paragraph.

I except, then OOo found all occurrences "o" in every paragrapg.
If click to "Find All", is found only one "o" too.

Thanks
Comment 1 Rainer Bielefeld 2006-08-26 19:09:15 UTC
I checked with "2.0.2  German version WIN XP: [680m5(Build9011)]" 
 "1.1.4 (German) WIN XP: [645m52 (Build 8824)]"
and can confirm the problem. Using my testfile "mytest.odt" you will find all
"o" in "word" searching forward (details as reported), but only the last one, if
you search backward.
Same with "o" in bold and for "search and replace"
Comment 2 Rainer Bielefeld 2006-08-26 19:10:27 UTC
Created attachment 38783 [details]
document demonstrates the problem
Comment 3 Rainer Bielefeld 2006-08-26 19:11:05 UTC
Due to Additional comments from rainerbielefeld Sat Aug 26 11:09:15 -0700 2006 
Comment 4 michael.ruess 2006-08-29 08:03:24 UTC
Reassigned to SBA.
Comment 5 stefan.baltzer 2006-08-31 15:05:33 UTC
SBA: The scenario "Find All", "Backwards" and "Format" (tried italic) finds only
in the last paragraph of the document. So if the last para does not have "o,
italic", nothing is found.
Reassigned to OS.
Comment 6 agrawalashish 2007-02-02 17:58:04 UTC
Created attachment 42698 [details]
search for T specifying T as in italics and check backwards option in the search dialogue box
Comment 7 agrawalashish 2007-02-02 17:59:15 UTC
“My search results were unexpected each time when I opened the attached word 
document using the Open-Office 2.0.3 and 2.1 build on Linux Content OS Release 
4.4, and tried to open this document using the (Kernel Red 2.6.9-
42.03.EL.CSE.smp) Linux build. I also rebooted in Windows XP Home or 
Professional Edition (Service Pack 2) using open-office 2.0.3 and 2.1, I 
reproduced the same problem.
When I tried to open any other normal word document in Linux and Windows XP I 
was able to load the document and getting the expected search results if done 
forwards without any problem.â€
Comment 8 Marcus 2017-05-20 11:22:00 UTC
Reset assigne to the default "issues@openoffice.apache.org".