Issue 70100

Summary: memory leak(?) when opening empty file as certain filetype
Product: Writer Reporter: robklg <rob.kleingunnewiek>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: ahz001, issues
Version: OOo 2.0.3Keywords: oooqa
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description robklg 2006-10-04 15:24:47 UTC
Hi, I did the following on OpenOffice 1.9 on Linux and OpenOffice 2.0.3 on Windows:

- create an empty file (I.e.: using "touch <filename>" in Linux
- open with Openoffice (I.e.: using "soffice <filename>"
- now OpenOffice will ask how to open it, click on 'HTML Document' or 'Help content'

Now OpenOffice will open the file but instead of being unable to open it, or to
show an empty file it shows 1.5 KB of some (possibly) "random" memory.

I have not tested other document formats, but there may be others that have the
same problem.

Out of curiosity I searched my disk to see where this data comes from. It turns
out the exact content also is inside the files sg30.sdv and sg100.sdv, one of
them is probably loaded in memory.

It is interesting that it stores the 1,5KB to disk without asking the user for
saving the file.

Anyway, it looks like a buffer underrun of some type, expecting 1,5KB of file
contents at a specific memory location i would think.
Comment 1 aziem 2006-10-04 15:36:39 UTC
I confirm the problem with OOo 2.0.4rc2 on Linux.  BTW, the problem does not
occur when the file has as little as 1 byte.
Comment 2 thorsten.martens 2006-10-16 10:15:07 UTC
TM->SBA: Reproducible ! According to AS this might be a problem within the
HTML-Filter. If you choose OpenDocument Text from the filter-selection dialog
you will get the expected "General input/output error". Please have a look.
Comment 3 stefan.baltzer 2006-11-09 18:07:04 UTC
SBA->AMA: Please proceed.
Comment 4 Mathias_Bauer 2007-12-04 15:08:15 UTC
target 3.0
Comment 5 Mathias_Bauer 2007-12-04 15:08:43 UTC
wrong component
Comment 6 andreas.martens 2007-12-04 15:26:22 UTC
ama->mav:
As discussed, in
sw/source/ui/app/docsh.cxx
SwDocShell::StartConvertFrom(..) calls rMedium.IsStorage()
and I watched during debugging that the stream buffer get filled with1500 bytes
when IsStorage() is called?!
Comment 7 Mathias_Bauer 2008-04-25 14:05:02 UTC
target 3.x
Comment 8 Marcus 2017-05-20 11:18:04 UTC
Reset assigne to the default "issues@openoffice.apache.org".