Issue 70183

Summary: document back/forward navigation buttons
Product: General Reporter: gyll <gyll>
Component: uiAssignee: AOO issues mailing list <issues>
Status: CLOSED DUPLICATE QA Contact:
Severity: Trivial    
Priority: P4 CC: elish, issues, rainerbielefeld_ooo_qa
Version: OOo 1.0.0   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description gyll 2006-10-07 17:49:19 UTC
Will you guys just put the back/forward navigation button in the OOo components
or should i reverse my OOo advocacy campaign? This is plain outrageous.
I looked over the posted issues and i found Issue 13647
http://www.openoffice.org/issues/show_bug.cgi?id=13647 (which also references 
Issue 5608 http://www.openoffice.org/issues/show_bug.cgi?id=5608 ) dating from
the dinosaurs era (i.e. OOo 1.x), but i still see no resolution. Why on earth
does it take YEARS to have such a super-simple feature added on? I just want
these two buttons next to the "navigator" button in the "Standard" toolbar,
what's so hard about that?

Don't you guys realize that a document without hyperlinks is plain crippled, and
having hyperlinks in a document is COMPLETELY USELESS without a minimal
navigation features in OOo (i.e. without back and forward buttons i'm spending
more time thinking about wether to click on a link or not then reading the
document, for how much longer you think users will accept this?)
Comment 1 thorsten.martens 2006-12-22 08:53:15 UTC
TM->requirements: Not a defect but might be a wish for an enhancement, so please
have a look.
Comment 2 gyll 2006-12-22 11:38:12 UTC
Hi,

I really thought i'll never get a reply to this issue, thought that my extreme
frustration with not being able to browse a document translated into a much too
harsh language (by my own standards it's been plain rude). So first of all,
please accept my apologies for the language...

Now that we're here, i'd like to add one more request (section "would be nice to
have") to this hyperlinks navigation thigie (apart from the minimal fwd/back
buttons): maybe you could also add a "open in new window" in the hyperlinks'
context menu (just like in mozilla). Until OOo will become tabs-based it's the
closest thing to what people are used to (i.e. back, fwd, new window/tab)


So, to rise:
Back and Forward buttons next to the Navigation button in the std bar
"Open in new window" in the hyperlinks' context menus -> would be nice to have


Cheers!
Comment 3 Edwin Sharp 2014-02-23 14:40:41 UTC
F5
Comment 4 Rainer Bielefeld 2014-04-11 04:43:47 UTC
(In reply to Edwin Sharp from comment #3)
> F5

The request has nothing to do with Navigator, but with Navigation icons you see in LibO, what are similar to Internet Browser Back / Forward icons.

So this one is a DUP of "Issue 5608 - Navigation button on OOo for hyperlink navigation (provide browser-like back/forward buttons) "

*** This issue has been marked as a duplicate of issue 5608 ***