Issue 71686

Summary: XY charts without valid x values are not imported correctly from Excel
Product: General Reporter: tony.galmiche.ooo
Component: chartAssignee: kla <thomas.klarhoefer>
Status: CLOSED FIXED QA Contact: issues@graphics <issues>
Severity: Trivial    
Priority: P3 CC: IngridvdM, issues, utomo.prawiro, weizhao
Version: 3.3.0 or older (OOo)Keywords: ms_interoperability, oooqa, usability
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 72764    
Attachments:
Description Flags
Nuage_Points.xls
none
patch_081010 none

Description tony.galmiche.ooo 2006-11-18 12:25:51 UTC
Nuage_Points.xls : clouds of points from Excel are not not imported correctly in
Calc.

DR : This is an XY chart without valid X values (the X values point to range
A2:A7 which contains strings). Excel has an internal fall-back to the values 1,
2, 3, ... but Calc simply drops the data points. The source ranges themselves
are imported correctly. 

IHa : The same problem did exist already in the old chart. So it would be nice
if you could submit an issue for that (without starting the summary with 'new
chart:').
Comment 1 tony.galmiche.ooo 2006-11-18 12:26:21 UTC
Created attachment 40672 [details]
Nuage_Points.xls
Comment 2 utomo99 2006-11-19 06:32:31 UTC
confirmed. on win xp OOo 2.1, office 2003.
The chart is NOT Showing.
Comment 3 IngridvdM 2006-11-20 17:09:08 UTC
accepted
Comment 4 IngridvdM 2007-04-03 16:32:45 UTC
changed type to defect
Comment 5 IngridvdM 2007-09-11 16:24:54 UTC
changing target because of limited resources
Comment 6 IngridvdM 2008-07-22 14:21:43 UTC
reset to new
Comment 7 weiz 2008-10-16 03:36:16 UTC
Created attachment 57147 [details]
patch_081010
Comment 8 weiz 2008-10-16 03:37:31 UTC
@iha: The patch is submitted, please let me know your suggestions. Thank you!
Comment 9 IngridvdM 2009-01-12 15:38:30 UTC
@weiz, thanks for the patch. It fixes the problem, but there is still room for
improvement. With the current approach it is not possible to have regression
lines for these kind of charts. Furthermore charts with empty cells within the x
ranges now look completely  different (see example doc at issue 3411). I adapted
the fix accordingly to avoid those problems. Simple numbering now is used only
when there is text somewhere within the x-values range.

Fixed in CWS chart35.
Comment 10 IngridvdM 2009-01-19 14:16:42 UTC
@Kla, please verify in CWS chart35. Thanks!
Comment 11 kla 2009-02-06 14:55:03 UTC
Seen ok in cws chart35 -> verified
Comment 12 kla 2009-05-06 07:05:29 UTC
Seen ok in current master -> closed