Issue 71929

Summary: Cross-references not shown properly
Product: Writer Reporter: tuharsky <tuharsky>
Component: open-importAssignee: michael.ruess
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 2.0.4   
Target Milestone: ---   
Hardware: All   
OS: Linux, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on: 2593    
Issue Blocks:    
Attachments:
Description Flags
The test case none

Description tuharsky 2006-11-24 11:35:35 UTC
Hallo,

I have imported Word2003 DOC that contains cross-references. These work BETTER
in OOo than in Word2000(!!) because when You click at them, it at least brings
You to the referenced bookmark.

However, the references are not visible in the way as in Word.

Each reference bookmark represents a chapter, that is of course part of
numbering. In the places, where cross-reference is used, the referenced chapter
number is displayed.

I'm not able to reproduce this on OOo however. There is just blank field in the
place of cross-reference. I can enter into editation mode, the reference is set
there, however the chapter number is never displayed. Does the Word2003 have
some new class of handling the cross reference?

The behaviour is quite self-explaining. You can create a document, create
bookmarks for chapters, and then cite the chapter numbers correctly even if
numbering has changed during document editation.

I must also say, that I was unable even to CREATE such document from the scratch
in OOo. I can only reference to the chapter name, not the numbering.

I think the function is quite important for any larger document that use
numbering and references to the chapters.
Comment 1 michael.ruess 2006-11-24 12:11:28 UTC
Please check if this is the same problem as issue 2593.
Otherwise please attach the sample document. Thanks a lot!
Comment 2 tuharsky 2006-11-24 13:47:21 UTC
Well, it depends.

If we look strictly at the beginning of issue, this is compatibility problem
more than a UI problem. The facts are, that an ordinary document from Word2003,
with no rocket since inbound, is incorrectly opened in OOo Writer -the
crossreferences are not displayed, and in fact, lost from user's or document
usability view.

If we take it this way, then this is an import issue that probably depends on
fixing 2593.

I'll submit a test case ASAP, must ask the partner for extraction of some benign
parts of the legal document..
Comment 3 michael.ruess 2006-12-13 08:05:46 UTC
Any updates on this?
Maybe you can send me the confidential document directly and I will build a new
one from the scratch using the same field types but different content (I will
delete right after this).
Comment 4 tuharsky 2006-12-13 10:35:18 UTC
Created attachment 41392 [details]
The test case
Comment 5 michael.ruess 2006-12-13 16:52:20 UTC
I can see now. In deed, it is the same problem as issue 2593.
In the attached document, there are references to numbered paragraphs. Writer is
not able to process it, because of missing UI AND core.
Currently, it would be possible to refer to the Chapter numbers - when used. You
have to enable the correct settings in "Tools.Outline Numbering" and then use
the assigned heading styles in the document.

*** This issue has been marked as a duplicate of 2593 ***
Comment 6 michael.ruess 2006-12-13 16:52:55 UTC
Closed.