Issue 7211

Summary: Visio 2000 file support
Product: Draw Reporter: Unknown <non-migrated>
Component: codeAssignee: AOO issues mailing list <issues>
Status: REOPENED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: horkana, issues, kpalagin, pagalmes.lists
Version: OOo 1.0.1   
Target Milestone: ---   
Hardware: PC   
OS: Linux, all   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description Unknown 2002-08-23 15:07:21 UTC
Be able to open in OO Drawing tool Visio 2000 files (.vsd files)
Comment 1 wolframgarten 2002-08-23 15:19:25 UTC
Set to new.
Comment 2 wolframgarten 2002-08-23 15:19:48 UTC
Reassigned to Falko.
Comment 3 horkana 2002-08-23 21:29:06 UTC
While this would be a very cool feature it is unlikely to happen.  
Caolan McNamara has said that reverse engineering Visio would be very
very unpleasant (and he should know he reverse enigineered the
Microsoft Word format).   

An easier more attainable target might be to try and get support for
the Visio XML based file format .VXD i think it is the extension it
uses.  
Comment 4 horkana 2002-08-23 21:32:50 UTC
This visio related bug report might be of interest:
MS Word Input filter cannot handle linked Visio objects
http://www.openoffice.org/issues/show_bug.cgi?id=3884
(it is requesting support for linked OLE objects)
Comment 5 Unknown 2002-08-27 17:06:17 UTC
Alan, you're right with OLE (issue 3884).  the original Visio 
drawing was received embedded into a Word document (word 2000).

As part of a pilot project trying to demonstrate the ability of 
OOffice to coexist and live inside an MS Office-equiped 
organisation, this improved OLE issue plus the .vxd support 
should be a good way to work around the problem and give to users 
viable, near transparent, alternative to MS Office.

I agree also on the .vsd/.vxd orientation, simpler this way.  
MSDN is giving more support to develop around .vxd than .vsd :-)

Comment 6 horkana 2002-09-04 20:27:10 UTC
> the original Visio drawing was received embedded into a Word
document (word 2000).

In that case perhaps you would consider marking this as a duplicate of
bug 3884  
Or if you want to leave this open as a seperate bug, you might want to
clarify, perhaps change the summary to include the ".vxd" or "Visio
XML".  You might also consider changing the OS and platform to All,
unless you think there is something specific about this problem to
Linux.  

If you do decide to close this as a duplicate, then who ever is doing
Quality assurance before closing issues should probably make sure to
copy any relevant information from this bug report to bug 3884.  
Comment 7 Unknown 2002-09-04 21:12:51 UTC
On Alan's suggestion.  This issue is marked as duplicate of issue 
3884.
here some extra keywords to guide further dev. efforts.

"Beginning with Microsoft Visio 2002, you can save Microsoft 
Visio drawings, stencils, and templates as XML (Extensible Markup 
Language) files and open them again in Visio without any loss of 
information. You can also include XML data from other 
applications within your XML data in Visio, provided the data 
contains well-formed XML that complies with the XML schema in 
Visio and the internal rules of Visio."

"The three XML file formats in Visio correspond to the three 
types of Visio files: XML drawing files have the .vdx file name 
extension; XML template files have the .vtx file name extension; 
and XML stencil files have the .vsx file name extension. These 
files function in the same way as their binary counterparts 
(.vsd, .vst, and .vss, respectively)."



*** This issue has been marked as a duplicate of 3884 ***
Comment 8 michael.bemmer 2003-03-11 17:19:50 UTC
As mentioned on the qa dev list on March 5th I will close all resolved duplicate
issues. Please see this posting for details. First step in IssueZilla is
unfortunately to set them to verified.
Comment 9 michael.bemmer 2003-03-11 17:57:45 UTC
As mentioned on the qa dev list on March 5th I will close all resolved duplicate
issues. Please see this posting for details. 
Comment 10 aziem 2005-10-08 15:21:31 UTC
*** Issue 52530 has been marked as a duplicate of this issue. ***
Comment 11 kpalagin 2007-05-15 21:13:41 UTC
*** Issue 9312 has been marked as a duplicate of this issue. ***
Comment 12 kpalagin 2007-05-15 21:20:17 UTC
*** Issue 71990 has been marked as a duplicate of this issue. ***
Comment 13 kpalagin 2007-05-15 21:25:23 UTC
Reopening as this one is not dup of 3884, but very separate issue.
Comment 14 micrond 2008-10-03 20:44:47 UTC
VXD support would be a good start but as a mac "switcher" all my vsd files are
now useless. Even though, OOo support VXD, I won't be able to convert these old
VSD to VXD unless some sort of converter or batch converter exist somewhere. 
So I would really suggest to keep VSD format as the long term target.
Comment 15 Rob Weir 2013-07-30 02:19:10 UTC
Reset assignee on issues not touched by assignee in more than 2000 days.