Issue 72187

Summary: Please provide regex example for "end of paragraph" in online/offline Help
Product: documentation Reporter: superandrzej <superandrzej>
Component: Online helpAssignee: stefan.baltzer
Status: CLOSED FIXED QA Contact: issues@documentation <issues>
Severity: Trivial    
Priority: P3 CC: issues, kpalagin, pagalmes.lists
Version: OOo 2.0.4   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description superandrzej 2006-12-01 18:03:55 UTC
It is possible to find and replace some Non-printing Characters e.g.:
"\t" is for tab. But it is not possible or at least not described in the help in
List of Regular Expressions, how to find and replace "end of paragraph"
character. In MS Word it is possible "^v"
BTW. Information about special characters are accessible directly from find and
replace window in OO.o also would be nice to have it nearby.
Comment 1 superandrzej 2006-12-01 18:09:41 UTC
sorry. I missed few words. The last paragraph was supposed to look like this:

"BTW. Information about special characters is accessible directly from find and
replace window in MS Word. It would be nice to have it also in OO.o nearby."
Comment 2 michael.ruess 2006-12-01 18:31:47 UTC
Reassigned to SBA.
Comment 3 kpalagin 2006-12-09 09:52:33 UTC
superandrzej,
paragraph end can be found with the dollar sign ($) (that is reflected in User 
Guide (http://documentation.openoffice.org/manuals/index.html).
paragraph end can be inserted with "\n\n" (this is not reflected in User 
Guide, so I am asking for this usefull addition).

Online Help should provide this information too, so I am changing component to 
documentation, type to enhancement, confirming and changing summary.


Comment 4 superandrzej 2006-12-09 13:19:59 UTC
Thanks for the info but this not only the problem of online documentation. 
When it comes to finding the "end of paragraph" the online help is more 
informtive:

Find & Replace  -> List of Regular Expressions

$ 
This symbol represents the paragraph mark for use in a regular expression. For example,
using $ will only find the search term if it appears at the end of a paragraph. So, if one 
searches for, say, Peter at the end of a paragraph, enter Peter$ in the Search for box. 
Special characters (for example, blank spaces and character­
anchored frames) at the end of a paragraph are ignored.


but Offline help (2.0.4) is confusing:

Text Documents -> Searching and Replacing -> List of Regular Expressions
$
Only finds the search term if the term appears at the end of a paragraph. 
Special objects such as empty fields or character-anchored frames at the end 
of a paragraph are ignored. Example: "Peter$".

It would be great to update also offline help.

When it comes to replacing somenting with "end of paragrah" from what I've 
tried "\n" should be used and NOT "\n\n", other wise 2 "end of paragrah" sings 
will be inserted.
Comment 5 stefan.baltzer 2006-12-13 13:55:49 UTC
SBA: Not exactly a new request...
See issue 15666 and issue 28913 among others (didn't search further, but issue
15666 is already "Started")

*** This issue has been marked as a duplicate of 28913 ***
Comment 6 stefan.baltzer 2006-12-13 13:56:39 UTC
SBA: Closed.
Comment 7 superandrzej 2006-12-13 22:06:54 UTC
I disagree. It is not duplication of 28913. This one deals with lack of 
information in help both online and offline and 28913 deals with easing 
inserting regular expressions in find and replace window. The same topic but 
different issue.
Comment 8 Uwe Fischer 2006-12-14 16:06:54 UTC
What do you mean with "online help" versus "offline help"?
What info is missing there? Is this about missing functionality in the software
or about missing documentation of features that are present in the software?
Comment 9 superandrzej 2006-12-14 18:26:06 UTC
It is about missing documentation of features that are present in the software.
offline - attached with the software and accessible through F1
online - http://documentation.openoffice.org/manuals/index.html
Comment 10 frank.thomas.peters 2006-12-15 08:13:31 UTC
superandrzej: 
please open a separate issue for the manuals (subcomponent "manuals"). Thanks.
Comment 11 grsingleton 2006-12-15 12:34:43 UTC
No need. The user guide already has a reasonable example and has had this since
1.1.x. If you or the submitter can offer something better please add it to 
29679. All a new issue will do is confuse things.
Comment 12 superandrzej 2006-12-15 14:24:46 UTC
@ grsingleton

In user guide an example concerning finding "end of paragraph" is just fine but
an example about inserting "end of paragraph" was missing.

Still the documentation included in Openoffice with respect to this case is
worst than user guide and need changes.
Help included in software is mostly the first place people look for information
and this was also my case.
Comment 13 grsingleton 2006-12-15 15:00:34 UTC
-> superandrzej@openoffice.org You said
> In user guide an example concerning finding "end of paragraph" is just fine but
an example about inserting "end of paragraph" was missing.

What is wrong with:
"Finds a hard row break that was inserted with Shift+Enter. To change row breaks
into paragraph breaks, enter \n in the Search for and Replace with boxes, and
then click the Replace all button." This statement is quite similar to what is
in Help. Perhaps the language used is TOO English. Is this possible? If yes,
please post a update to 29679
Comment 14 superandrzej 2006-12-15 16:35:16 UTC
From OO.o 2.0.4
"\n Represents a line break that was inserted with the Shift+Enter key
combination. To change a line break into a paragraph break, enter \n in the
Search for and Replace with boxes, and then perform a search and replace."

For me this wording means that \n stands for "line break" and one have to use a
lot of imagination to interpret it other way. The example provided suggests that
only "line breaks" can be converted into "paragraph breaks" with \n. As it is
right now is not as clear as it should. I'm not native English speaker but for
me e.g.:
" \n - when 'searching for' stands for "line break" that was inserted with the
Shift+Enter key combination but when 'replacing with' stands for "paragraph break"

is shorter and more informative.
If I had this kind of information I would not file this bug.
Comment 15 grsingleton 2006-12-15 17:02:08 UTC
Since you wish to reword the Regular Expression table from Chapter 2 of the User
Guide, I suggest that you get the latest version from 29679, edit it and then
attach your editied version to the issue. This action will help. If you choose
not to do this, it is doubtfull any correction will make it to the next edition.
Please label your edited chapter with your initials in the filename and remember
not to alter the overall formatting of the file so it can be integrated
correctly into the master document.
Comment 16 superandrzej 2006-12-16 19:07:07 UTC
Not that I want to reword Regular Expression table from Chapter 2 of the User 
Guide but only a small part of it. I can change this in User Guide. But I'm 
not a native speaker, it would be nice if a native speaker would review it 
afterwards.
but what about the Help attached with the software? Will this change have any 
impact on offline Help?
Comment 17 grsingleton 2006-12-16 19:57:59 UTC
-> superandrzej:
I suggest that you get the latest version from
http://www.openoffice.org/issues/show_bug.cgi?id=29679, edit it and then
attach your editied version to the issue. Please label your edited chapter with
your initials in the filename and remember to enable both Show and Record in
Edit > Changes and please do not alter the overall formatting of the file. You
need not be concerned about language skills as the update will be reviewed by a
native English speaker.  I hope that what you do is also useful in the Online Help.
Comment 18 Uwe Fischer 2007-01-02 13:58:31 UTC
Changed application help (formerly known as online help) file
shared/01/02100001.xhp to state the following:
\n
Represents a line break that was inserted with the Shift+Enter key combination.
To change a line break into a paragraph break, enter \n in the "Search for" and
"Replace with" boxes, and then perform a search and replace.
\n in the "Search for" text box stands for a line break that was inserted with
the Shift+Enter key combination.
\n in the "Replace with" text box stands for a paragraph break that can be
entered with the Enter or Return key.
Comment 19 stefan.baltzer 2007-05-06 10:50:38 UTC
SBA: OK in OOo-Dev 680m211. Set to fixed.
Comment 20 stefan.baltzer 2007-05-06 10:51:35 UTC
Set to verified.
Comment 21 stefan.baltzer 2007-05-06 10:52:17 UTC
Closed.