Issue 72354

Summary: New bibliography entries get lost
Product: Writer Reporter: sschuberth <sschuberth>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Normal    
Priority: P3 CC: elish, issues
Version: OOo 2.1   
Target Milestone: ---   
Hardware: PC   
OS: Windows, all   
Issue Type: DEFECT Latest Confirmation in: 4.1.0-dev
Developer Difficulty: ---

Description sschuberth 2006-12-07 10:31:24 UTC
This is for 2.1 RC2 on Windows XP.

Goal: I want to define a new bibliography entry in the document, but not insert
any references to it yet.

Steps to reproduce:
- Choose "Insert -> Indexes and Tables -> Bibliography Entry...".
- Choose "From document content" and "New".
- Define a bibliography entry and press "OK".
- Back in the previous dialog, verify the "Short name" lists your newly added
entry and press "Close".
- Again choose "Insert -> Indexes and Tables -> Bibliography Entry...".
- The entry you just added is gone from the "Short name" list.

As a work-around to this bug, you have to press "Insert" before pressing "Close"
in the "Insert Bibliography Entry" dialog and delete the inserted reference from
the document.
Comment 1 michael.ruess 2006-12-07 10:51:43 UTC
Reassigned to ES.
Comment 2 eric.savary 2006-12-08 07:15:54 UTC
This is not a bug.
The dialog is called "Insert Bibliography entry".
If you don't do Insert at the end, you don't insert any entry in the document,
which means, when you reopen the dialog, that "From document content" will be empty.

For usability reasons, one may rename "Close" into "Cancel".

Reassigned.
Comment 3 Edwin Sharp 2014-04-11 10:21:30 UTC
Confirmed with
AOO410m16(Build:9762)  -  Rev. 1585426
2014-04-07 10:29:13 (Mo, 07 Apr 2014)
Win 7