Issue 72398

Summary: Copy/Paste Tabs table FROM Notepad TO OOoWriter
Product: Writer Reporter: maestraccio <bcontra>
Component: open-importAssignee: eric.savary
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P4 CC: issues
Version: OOo 2.0.4Keywords: needmoreinfo
Target Milestone: ---   
Hardware: Other   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
source table
none
results in OOo Writer none

Description maestraccio 2006-12-08 15:13:22 UTC
When copy&pasting a table, made up from tab stops to separate fields, Writer
will not recognize them as field separators. MS Word does, though.

E.g. plain text:

 cell1 [tab] cell2 [tab] cell3 [enter]
 cell4 [tab] cell5 [tab] cell6 [enter]

will become in OOo:
---------------------------
|cell1 cell2 cell3|   |   |
|cell4 cell5 cell6|   |   |
---------------------------
|                 |   |   |
---------------------------

instead of:
-------------------------
| cell1 | cell2 | cell3 |
-------------------------
| cell4 | cell5 | cell6 |
-------------------------

When selecting all empty cells before copying, this is what happens in the other
cells:

c#e#l#l#1#	#c#e#l#l#2#	#c#e#l#l#3#
Comment 1 michael.ruess 2006-12-08 16:07:37 UTC
Reassigned to ES.
Comment 2 eric.savary 2006-12-11 10:18:39 UTC
I cannot reproduce it.
What do you mean exactly?
1) copy/pasting plain text table doesn't become a formatted table in OOo? -> not
a bug.

2) copy/pasting plain text table and transform txt->tabel doesn't recognize the
tabs? -> I cannot reproduce it.

Please add a sample document and a step by step description of what you do, get
and expect.
Comment 3 maestraccio 2006-12-11 21:19:21 UTC
Created attachment 41345 [details]
source table
Comment 4 maestraccio 2006-12-11 21:20:42 UTC
Created attachment 41346 [details]
results in OOo Writer
Comment 5 maestraccio 2006-12-11 21:21:13 UTC
Step 1:
Create a plain text table such as:

cell1	cell2	cell3
cell4	cell5	cell6

Note that between the entries "cell1" and "cell2" (etc) are tabs, not spaces.
Please use attached source file table.txt and do not copy&paste this sample.

Step 2:
Create a table in OpenOffice.org Writer, 3 columns, 2 rows

Step 3:
select all 6 cells.

Step 4:
copy table FROM Notepad (or any other plain text editor)

Step 5:
paste the content INTO the empty table cells in OOo.


In OOo this will result in ALL content in cell1 (upper left) and # in all other
cells. In MSWord this would result in the word "cell1" in the upper left cell,
"cell2" in the one next to it, etc, just like the plain text.
Comment 6 eric.savary 2006-12-13 14:45:47 UTC
duplicate

*** This issue has been marked as a duplicate of 24500 ***
Comment 7 eric.savary 2006-12-13 14:46:02 UTC
Closed