Issue 72452

Summary: crash when closing a document while a context menu on a floating window is open
Product: Base Reporter: Frank Schönheit <frank.schoenheit>
Component: codeAssignee: carsten.driesner
Status: CLOSED FIXED QA Contact: issues@dba <issues>
Severity: Trivial    
Priority: P2 CC: issues, stefan.baltzer
Version: 680m193Keywords: regression
Target Milestone: 3.4.0   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
document to reproduce the bug case none

Description Frank Schönheit 2006-12-11 08:40:53 UTC
- open the attached database document
- create a new empty form
- open the form navigator (from the "Form Design" Toolbar)
- with a right mouse click, open the context menu of the navigator tree's root entry
- while the context menu is open, press Ctrl-W, which should close the form
=> crash
Comment 1 Frank Schönheit 2006-12-11 08:41:45 UTC
Created attachment 41317 [details]
document to reproduce the bug case
Comment 2 Frank Schönheit 2006-12-11 08:45:42 UTC
This does not crash in 2.0, but in all versions from 2.0.1 to 2.1RC1
Comment 3 Frank Schönheit 2006-12-11 12:03:44 UTC
has nothing to do with embedded documents, or the form navigator in particular
... easier way to reproduce:
- open a new text document
- open the stylist
- in the stylist, open a context menu
- while the context menu is still open, press Ctrl-W to close the document
=> crash

fs->mba: Looks like a framework issue to me. If there's an open context menu in
the document window itself, then closing is denied. The same should happen in
floating windows which belong to the document, /me thinks.
Comment 4 Frank Schönheit 2006-12-11 12:05:31 UTC
should have assigned this to cd instead of mba nowadays ...
Comment 5 carsten.driesner 2006-12-19 14:28:13 UTC
cd: Accepted.
Comment 6 Mathias_Bauer 2008-01-11 09:38:52 UTC
target 3.0
Comment 7 Mathias_Bauer 2008-07-08 17:31:25 UTC
code freeze missed, target adjusted
Comment 8 carsten.driesner 2009-01-27 13:44:19 UTC
We are short before code freeze for OOo 3.1. As time is running out I have to
shift this issue to 3.2.
Comment 9 carsten.driesner 2009-09-15 09:31:23 UTC
cd: Due to missing time I have to shift this patch to the next release.
Comment 10 carsten.driesner 2010-07-02 15:45:25 UTC
cd: This issue needs a lot of time to fix it right. Even introducing an
asynchronous command processing didn't help. We have to think about a new way to
handle this special situation. As this problem can be easily avoided by the user
I set it to the next release. May be we have more time to work on it.
Comment 11 carsten.driesner 2011-02-11 14:22:48 UTC
cd: Checked and found fixed in DEV300m99.
Comment 12 stefan.baltzer 2011-02-11 15:06:15 UTC
SBA->CD: As (not) seen on Mac, Linux, Windows: Neither reproducible in OOo 3.3,
nor DEV300_m99. Probably fixed "along the way" in the GSL area. Not worth
searching what change did it.

Closing issue.