Issue 72481

Summary: Misplaced right-tab marker in index using hanging indent
Product: Writer Reporter: mwtoews <mwtoews>
Component: formattingAssignee: michael.ruess
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 2.0.4   
Target Milestone: ---   
Hardware: All   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Example_indent_file
none
View in Word none

Description mwtoews 2006-12-12 05:56:35 UTC
This curious bug affects the formating produced in OOo Writer; however it does
not have a truly visible effect until saved and viewed in Microsoft Word.  The
formatting error is created by the "index and tables" feature for "Illustration
Index" or "Table of Contents" with a hanging indent (accomplished in Writer by
setting "Before text" and "First line" to equal, but opposite values -- such as
1.00 cm and -1.00 cm). Certainly, hanging indents are desired in indexes where
the text is considerably long, and wraps to more than one line.

For example:
(1) In a fresh Writer document, insert an image, and right-click it and give it
a long caption.
(2) Insert an Illustration index at the top of the document. You should
hopefully see the illustration caption wrap at least two lines (if not add more
caption text, then "Update Index"
(3) To give the "Illustration Index 1" style a hanging indent, modify the style
(via F11) and set "Before text" to 1.00 cm and "First line" to -1.00 cm.
(4) Beautiful. However, right-click the index, and unselect the "Protect against
manual changes" option, click outside of the style, then click back on the
"Illustration Index 1" style for the index caption. You should observe on the
ruler at the top that the right-tab is approximately 19.59 cm -- or 2.00 cm to
the right of the paragraph marker. Certainly, the right-tab marker should be at
the same position  of the paragraph marker (and it is -- if we don't use a
hanging indent).  However, curiously it is exactly a multiple of 2 of the
"hanging indent" (or possibly mathematically as "before_text + first_line").
(5) If you have Microsoft Word available to you, save this document as a *.DOC
file, and view it there, and you shall see that the right-tab is where the text
wants to go to (rather then to the right paragraph marker -- as is the case for
Writer).

I have found it impossible to "trick" the right-tab marker to move to where it
should by modifying the "Illustration Index 1" style tab position from 17.59 cm
to 16.59 cm (relative distance? not absolute?), and applying that style.
However, when I select "Update Index/Table", this formatting is lost back to the
incorrectly placed right-tab marker.

I believe that the placement of the right-tab marker is miscalculated, when a
hanging indent is used -- this is where I expect to find the bug for this scenario.
Comment 1 mwtoews 2006-12-12 05:57:31 UTC
Created attachment 41351 [details]
Example_indent_file
Comment 2 michael.ruess 2006-12-12 09:26:22 UTC
Reassigned to ES.
Comment 3 eric.savary 2007-03-16 10:42:47 UTC
@MRU: the problem is actually a word export problem (see following screenshot).
Comment 4 eric.savary 2007-03-16 10:44:24 UTC
Created attachment 43739 [details]
View in Word
Comment 5 michael.ruess 2007-03-16 11:35:44 UTC
It's the difference between Word and Writer - both have the tab stop defined
right of the paragraph border (at19,59 cm). But only Word is able to place text
at this tab stop outside the paragraph borders.
Already tracked in issue 62072.

*** This issue has been marked as a duplicate of 62072 ***
Comment 6 michael.ruess 2007-03-16 11:36:36 UTC
Closing duplicate.