Issue 72696

Summary: uno exe killed by URP SIGPIPE
Product: udk Reporter: Stephan Bergmann <stephan.bergmann.secondary>
Component: codeAssignee: AOO issues mailing list <issues>
Status: ACCEPTED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues
Version: current   
Target Milestone: 4.x   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description Stephan Bergmann 2006-12-18 09:57:14 UTC
At least on SRC680m196 unxlngi6.pro, it sometimes happens that

  > cd .../testtools/unxlngi6.pro/lib
  > ./bridgetest_javaserver &
  > ./bridgetest_client

does not succeed (it appears that this happens more often with Java 6).  The
reason is that the client queries for an unknown type, the server responds by
closing the connection, but the client continues with issuing two consecutive
sends (with no intervening recvs) of which the second causes SIGPIPE.  This can
be worked around (on Unix) by setting sigaction of SIGPIPE to SIG_IGN, so that
the send returns with EPIPE instead.
Comment 1 Stephan Bergmann 2006-12-18 10:52:49 UTC
.
Comment 2 Martin Hollmichel 2007-12-07 13:00:20 UTC
set target to 3.x according to http://wiki.services.openoffice.org/wiki/Target_3x
Comment 3 Stephan Bergmann 2008-02-26 08:24:29 UTC
The thread starting at
<http://api.openoffice.org/servlets/ReadMsg?list=dev&msgNo=19085> describes the
same or at least a very similar problem.  I need to do more investigation before
finally deciding whether or not setting SIGPIPE to SIG_IGN is the correct and
best solution, but for OOo 3.0 it might well be a good quickfix.
Comment 4 Marcus 2017-05-20 11:31:02 UTC
Reset assigne to the default "issues@openoffice.apache.org".