Issue 72828

Summary: Hypertext link and animation result in incorrect or missing links
Product: Impress Reporter: dbs <dan.scott>
Component: formattingAssignee: wolframgarten
Status: CLOSED FIXED QA Contact: issues@graphics <issues>
Severity: Trivial    
Priority: P2 CC: issues, liujianli, pagalmes.lists, rbircher
Version: OOo 2.1   
Target Milestone: OOo 3.0   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 72764    
Attachments:
Description Flags
Demonstrate failure of links + animation
none
the patch of i72828
none
I have revised the patch,please check it.
none
the patch of i72828 none

Description dbs 2006-12-21 00:49:02 UTC
If you add animations to text that contain hypertext links, the animation
prevents you from being able to click on the link. For example:

* First link: http://cbc.ca
* Second link: http://cnn.com
* Third link: http://news.google.com

If I don't add any animations, then all the links work as expected.

If you place your cursor in the first bullet and add an animation to it, then
display the presentation, the link for the second link actually shows up around
the area of the "Second link" text rather than the URL itself -- and the link
for the third link is nowhere to be found.

It looks almost as though Impress is shifting the location for each link to the
left, so that by the third link the location is off the left margin of the
screen and can't be found. In any case, it makes it impossible to use animations
+ links on the same slide. 

The problem occurs in 2.0.4 and 2.1. I haven't tried to recreate this with
earlier versions of OOo.
Comment 1 dbs 2006-12-21 01:00:14 UTC
Created attachment 41614 [details]
Demonstrate failure of links + animation
Comment 2 dbs 2006-12-21 01:01:39 UTC
Just reproduced the issue on OOo 2.0.2 (running on Ubuntu Linux this time) and
uploaded a sample presentation demonstrating the problem. I see the same problem
with 2.0.4 and 2.1.0 on Windows XP.
Comment 3 thb 2006-12-21 11:05:00 UTC
Reproducible. Accepted & set a target.
Comment 4 thb 2006-12-21 11:05:25 UTC
.
Comment 5 claudeabcd 2007-01-02 21:50:09 UTC
Same here for me. I tried with hyperlinks to a web page, a slide in the 
slideshow and a reference to an external file (pdf) and all failed. Using 
Windows2000 pro SP4 on AMD Athlon 1200Mhz machine. All the animation WITH  
hyperlinking trials worked on Power Point 2000 and 2002.

Thanks for posting this bug - I'll watch for an eventual resolution to 72828
Comment 6 kaurj 2007-02-02 14:23:25 UTC
This bug was successfully reproduced on WinXP with OpenOffice Impress Build 
2.1 and on Linux with OO Build 2.0.4. Further follow-up testing gave some 
additional information. Consider the following reproduction steps:

1.	Open OO Impress Build 2.1 and create a new presentation. 
2.	Choose the Title, Text layout.
3.	In five bullets, type the following addresses: www.cbc.ca, 
www.google.com, www.investors.ca, www.micro.org, www.finance.net 
4.	Add different animations to each hyperlink text.
5.	View slideshow (F5).

I found that only the first hyperlink is still active after animations were 
added. However, any other hyperlink text was not active. Also, all hyperlinks 
directed the user to the respective website in the Normal Layout, but none 
were active in the Outline Layout. This is misleading to the user who is using 
the Outline Layout, since the hyperlinks are displayed but clicking on them 
does not redirect the user to that website.

Also note that the first link always appeared correctly, regardless of whether 
it was animated or not. Furthermore, if a non-animated hyperlink appears with 
animated ones, then the non-animated link is also broken. Links with many 
extensions were tested, including those from different countries, but the 
pattern did not change. Very rarely, it was found that the third hyperlink 
also became active, when there were more than 5 hyperlinks on the slide. Also, 
when the presentation is viewed, the position of the first link is active even 
when the slide appears blank and the hyperlink text has not yet come up on the 
screen.

The only way around to this problem seems to be avoiding animations on any 
hyperlink text.
Comment 7 liujl 2008-01-17 08:35:54 UTC
Created attachment 50936 [details]
the patch of i72828
Comment 8 liujl 2008-01-18 10:57:37 UTC
Created attachment 50961 [details]
I have revised the patch,please check it.
Comment 9 liujl 2008-01-23 10:35:44 UTC
Created attachment 51101 [details]
the patch of i72828
Comment 10 Martin Hollmichel 2008-01-25 17:16:40 UTC
set target to 3.0
Comment 11 thb 2008-06-20 16:28:20 UTC
Patch applied in CWS thb30fixes -> issue fixed.
Comment 12 thb 2008-06-25 10:54:56 UTC
Fixed in CWS thb30fixes, please verify (note that the hyperlink area is still
static, i.e. represents the final shape position - but the offsets are gone).
Comment 13 wolframgarten 2008-07-01 10:02:44 UTC
Verified - offset is gone.
Comment 14 Raphael Bircher 2008-07-16 01:09:49 UTC
Maybe I'm too bad, but I can't verify, that this issue is fixed. I tested it
with OOo DEV300_m24 on a Intel Mac with OS X 10.5.2

I open the attached Document
Start de full scren presentation with F5 key
On the first slide i can klick the links
on the secand i can't click it, no way.

So I will reopen this issue.

Add myself to CC
Comment 15 wolframgarten 2008-07-16 07:50:39 UTC
The CWS containing the fix, thb30fixes, is integrated in DEV300_m25 so you
cannot see any positive effect in m24.
Comment 16 Raphael Bircher 2008-07-16 22:19:59 UTC
Ok, thats my error, sorry. I will wait for the m25, test, and then close it, if
it all ok.
Comment 17 thorsten.ziehm 2008-08-14 12:38:38 UTC
set issue to status 'fixed'
Comment 18 thorsten.ziehm 2008-08-14 12:39:41 UTC
Raphael, please check in current version and close the issue. I set it to the
old status 'verified'.
Comment 19 Raphael Bircher 2008-08-14 16:12:46 UTC
testet with OOO300_m1. seams to be ok

Closing issue