Issue 73020

Summary: Wrong table formatting in exported PDF by Mail Merge to E-Mail
Product: Writer Reporter: Rainer Bielefeld <rainerbielefeld_ooo_qa>
Component: printingAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 2.0.2   
Target Milestone: ---   
Hardware: PC   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Testkit to reproduce the problem none

Description Rainer Bielefeld 2006-12-31 16:05:48 UTC
I checked with "2.0.2  German version WIN XP: [680m5(Build9011)]" and found out,
that the table formatting for a table in the heading of my documet looks wrong
after Meil Merge E-Mail.

Steps to reproduce:
1. Unpack my test kit to a folder 'C:\mailmergetest'
2. make 'testaddresses.odb' available for your OOo installation
3. Insert some useful existing  E-mail-addresses to column 'AG' in 'addresses.ods'
   and close 'addresses.ods'
4. Close and restart OOo
5. Open 'tabletest.odt'
6. Send Mail Merge e-mail using mail merge assistant
6.1. Menu 'Tools - Mail Merge Assistant - Current document' <continue>
6.2. Radio button 'E-Mail'  <continue>  <continue>  <continue>  <continue>
     <continue> (Until your  reach step 8.)
6.3. In step 8. of MMA select radio button 'send as E-Mail', select field
     "Email" for 'To', write some useful subject and select "send as 
     Adobe PDF document"  <send documents>
     documents will be sent
7. Now compare the heading in an e-mail attachment you have got with the 
   original heading ('tabletest.pdf' and 'tabletest_result.odt'): 
   Expected: headings look equal in both documents (odt / PDF)
   Actual:  in the new PDF the horizontal line between 
   "Bielefeld & Buß" and "Regelsysteme ...." has become a strike through
   for  "Bielefeld & Buß".

That ugly effect does not appear if you export the document with the normal PDF
export function.

I will test with 2.1 soon
Comment 1 Rainer Bielefeld 2006-12-31 16:08:37 UTC
Created attachment 41799 [details]
Testkit to reproduce the problem
Comment 2 Rainer Bielefeld 2007-01-01 11:23:56 UTC
Corrected Version
Comment 3 michael.ruess 2007-01-02 09:03:10 UTC
Reassigned to HI.
Comment 4 Rainer Bielefeld 2007-01-02 17:49:50 UTC
I also checked on an other PC with "2.1.0  German version WIN XP:
[680m6(Build9095)]", the problem is also reproducible with my testkit
'testkit_mailmergetest.zip'
Comment 5 Rainer Bielefeld 2007-01-02 18:03:24 UTC
For the sake of completeness: The "strike throug" is also visible in
otherviewsers Ghostview 4.7 and FoxitReader.
Comment 6 h.ilter 2007-01-04 10:24:05 UTC
HI->OS: Occurs also not by sending document by mail as pdf attachment.
Comment 7 Oliver Specht 2007-01-10 08:12:00 UTC
Reassigned to FME
Comment 8 Martin Hollmichel 2007-09-10 14:10:09 UTC
move to target 3.x according http://wiki.services.openoffice.org/wiki/Target_3x
Comment 9 Rainer Bielefeld 2008-12-19 05:43:04 UTC
I did some further tests with 3.0 and 3.1Dev, where the problem still is visible.

The problem is caused by the curious paragraph formatting. The red parting line
in the logo is not a table border, but the bottom border of the Paragraph
containing "Bielefeld & Buß oHG". When I delete this border and create a table
border line between that table cell and the one containing "Regelsysteme für
Heizungs-, Klima-, Lüftungstechnik", the problem disappears.

May be these hints help to fix the bug.