Issue 73173

Summary: Integate SoC project languageguessing
Product: Writer Reporter: thomas.lange
Component: codeAssignee: stefan.baltzer
Status: CLOSED FIXED QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues, rene
Version: OOo 1.0.0   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: FEATURE Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Document with sample text for various languages
none
text file listing all potentially available languages for language-guessing none

Description thomas.lange 2007-01-05 12:15:55 UTC
Language-Guessing as provided by the Google Summer of Code project should be
integrated.
Comment 1 thomas.lange 2007-01-05 12:16:35 UTC
.
Comment 2 thomas.lange 2007-01-12 08:35:51 UTC
Files changed:
- added new module 'libtextcat'
- added 'data' directory to lingucomponent
- added 'source/languageguessing' directory to lingucomponent

- offapi/com/sun/star/linguistic2/makefile.mk
- offapi/com/sun/star/linguistic2/LanguageGuessing.idl
- offapi/com/sun/star/linguistic2/XLanguageGuessing.idl

- svtools/inc/pathoptions.hxx
- svtools/source/config/pathoptions.cxx

- officecfg/registry/data/org/openoffice/Office/Paths.xcu

- scp2/source/ooo/directory_ooo.scp
- scp2/source/ooo/file_ooo.scp
- scp2/source/ooo/module_hidden_ooo.scp

- svx/source/editeng/editdbg.hxx
- svx/source/editeng/editview.cxx
- svx/source/editeng/eerdll.cxx
- svx/source/editeng/eerdll2.hxx

- sw/inc/swmodule.hxx
- sw/source/ui/app/swmodule.cxx
- sw/source/ui/inc/olmenu.hxx
- sw/source/ui/lingu/olmenu.cxx
- sw/source/ui/uiview/viewling.cxx
Comment 3 thomas.lange 2007-01-12 11:01:39 UTC
Further files changed:

- lingucomponent/prj/build.lst
- lingucomponent/prj/d.lst
Comment 4 thomas.lange 2007-01-16 09:27:23 UTC
.
Comment 5 thomas.lange 2007-01-18 09:48:58 UTC
*** Issue 39992 has been marked as a duplicate of this issue. ***
Comment 6 thomas.lange 2007-05-03 11:14:46 UTC
.
Comment 7 thomas.lange 2007-05-03 12:59:41 UTC
Created attachment 44838 [details]
Document with sample text for various languages
Comment 8 thomas.lange 2007-05-03 13:01:06 UTC
Created attachment 44839 [details]
text file listing all potentially available languages for language-guessing
Comment 9 thomas.lange 2007-05-03 13:13:49 UTC
TL->SBA: Please note that 

a) the first document holds some more sample texts than those available for
language-guessing.

b) due to some other problems already filed as issues Amharic and Vietnamese
will still show the red markings for misspelled word even though the language of
the paragraph was set correctly via the context menu.

c) due to problems not currently investigated/fixed some languages that yelled
completely incorrect results are temporarily disabled for the purpose of
language guessing. These are:
- Gaelic (Manx)
- Scots
- Tagalog
- Japanes
- Korean
- Chinese simpl.
- Chinese trad.
- Georgien
- Hindi
- Marathi
- Nepali
- Sanskrit
- Tamil
- Thai
- Quechua
- Yiddish
Comment 10 thomas.lange 2007-05-03 14:15:02 UTC
TL->SBA: Please also check with Office installation on other devices or unicode
characters (e.g. Chinese, Arabic) in the installation path.
Comment 11 stefan.baltzer 2007-06-14 17:38:22 UTC
SBA: Verified in CWS languageguessing.

URL to Spec:
http://specs.openoffice.org/appwide/linguistic/Automatic_Language_Guessing_Component.odt

URL to TCS:
http://qa.openoffice.org/ooQAReloaded/TestcaseSpecifications/OpenOffice.org_2.3/Word_Processor/Language_guessing.html

Please note that I modified the test document in order to prepare the automatic
tests.
It is available via the TCS link and will be updated along with it.
I have not yet removed the "non-working languages". The "Amharic issue" is
solved in another CWS, so these things will only "meet" in masterbild.
At times, Chinese, Japanese and Korean could be be tested with StarSuite only
because OOo has not CJK spellchecker (StarSuite supports Korean spell check).

Thus the TCS and the test document must be updated AFTER re-verification of this
feature in masterbuild.
Comment 12 stefan.baltzer 2007-06-14 17:40:14 UTC
SBA: Reassigned to me.
Comment 13 thorsten.ziehm 2009-07-20 15:20:05 UTC
This issue is closed automatically and wasn't rechecked in a current version of
OOo. The fixed issue should be integrated in OOo since more than half a year. If
you think this issue isn't fixed in a current version (OOo 3.1), please reopen
it and change the field 'Target Milestone' accordingly.

If you want to download a current version of OOo =>
http://download.openoffice.org/index.html
If you want to know more about the handling of fixed/verified issues =>
http://wiki.services.openoffice.org/wiki/Handle_fixed_verified_issues