Issue 74225

Summary: annoying dialog ("Text Import") when pasting plain text
Product: Calc Reporter: Frank Schönheit <frank.schoenheit>
Component: uiAssignee: frank
Status: CLOSED FIXED QA Contact: issues@sc <issues>
Severity: Trivial    
Priority: P3 CC: frank.loehmann, issues, matthias.mueller-prove, stuttgarter-ooo
Version: 680m202Keywords: usability
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description Frank Schönheit 2007-02-06 14:02:34 UTC
- open a plain text editor, or any other application whose (only) clipboard format
  is plain text
- in this application, copy some text which contains spaces to the clipboard
- in a spreadsheet, go to an arbitrary cell and press Ctrl-V, this way inserting
  the clipboard text into the cell
=> the "Text Import" dialog opens, asking for text import options

This is a usability issue. There's a "Paste special" functionality for a good
reason: "Paste" is expected to simply paste, with good defaults. At least this
is what I'd claim is most expectation conformant.
The current behavior is pretty annoying for a certain class of use cases.

I know that this behavior is a result of fixing issue 15509. However, note that
the original patch for this issue was intended to only affect Paste Special, not
plain paste. I think this is what we should revert to.
Comment 1 ooo 2007-02-07 11:03:05 UTC
> note that the original patch for this issue was intended to only affect
> Paste Special, not plain paste.

Actually not. Also the original patch hooks into the routine that is
called for the paste operation, regardless from where it originated.
Currently there is no mechanism to differentiate.
Comment 2 Frank Schönheit 2007-02-07 12:35:42 UTC
Ah, okay, perhaps I misunderstood mmeeks
Comment 3 ooo 2007-07-31 16:05:07 UTC
Targeting to OOo2.4
Comment 4 frank.loehmann 2007-11-27 15:32:31 UTC
FL->ER: Like discussed today. 

Proposal (no UI relevant changes):
Show Import Text dialog only when more than one row is pasted via clipboard.
The new "Text to column" feature, which will be introduced with SO 8 PU 10 (OOo
2.4), could be used to import text from a cell to columns in Calc. So there
would be no gap by changing the current behavior.
Comment 5 ooo 2007-12-21 17:02:56 UTC
In cws dr58:

sc/source/ui/view/viewfun5.cxx  1.49.158.2
Comment 6 ooo 2008-01-11 17:57:31 UTC
Reassigning to QA for verification.
Comment 7 royce2 2008-01-13 13:22:14 UTC
I agree that this remains an issue whether pasting a single row or a table of
several rows.  If I use Ctrl V to call up a paste, I should be entitled to
accept the consequences of that decision, including whatever format the material
may be in.  If I wish to check or query the format, it should be through Paste
Special.
Comment 8 oc 2008-01-17 16:55:35 UTC
verified in internal version cws_dr58
Comment 9 frank 2008-02-11 14:01:28 UTC
found integrated on master OOHm5 using Linux, Solaris and Windows build