Issue 7449

Summary: Allow customization of context menus
Product: General Reporter: lars <lars_o_hansen>
Component: uiAssignee: AOO issues mailing list <issues>
Status: CLOSED DUPLICATE QA Contact:
Severity: Normal    
Priority: P4 CC: arielch, ddaniels, elish, gleppert, icyfeet, irne.barnard, issues, jerome.bouat, joerg-walter, kbn, khirano, lista, masaya.k, netdragon, oooforum, patricklladones
Version: OOo 1.0.0Keywords: rfe_eval_ok
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: FEATURE Latest Confirmation in: 4.1.0-beta
Developer Difficulty: ---
Issue Depends on: 113382    
Issue Blocks:    

Description lars 2002-09-02 20:09:45 UTC
You allow to customize Menus ....


How about customizing context menus?  entries + behaviour(issue 7187)
Comment 1 thorsten.martens 2002-09-12 13:34:03 UTC
TM->FT: This one is a wish for a new feature, so please have a
look,...thanks !
Comment 2 eric.savary 2003-03-25 03:20:35 UTC
*** Issue 7783 has been marked as a duplicate of this issue. ***
Comment 3 eric.savary 2003-04-19 22:17:37 UTC
*** Issue 9349 has been marked as a duplicate of this issue. ***
Comment 4 eric.savary 2003-04-19 22:35:13 UTC
*** Issue 9348 has been marked as a duplicate of this issue. ***
Comment 5 eric.savary 2003-04-20 14:10:33 UTC
*** Issue 4834 has been marked as a duplicate of this issue. ***
Comment 6 eric.savary 2003-04-20 14:13:55 UTC
*** Issue 5502 has been marked as a duplicate of this issue. ***
Comment 7 jameslee 2003-04-20 16:41:02 UTC
Hello Eric, Mr Thickie here needing some help. How will providing a
customisable menu create a title case function and actually put it on
the menu?
Comment 8 falko.tesch 2003-10-08 14:11:21 UTC
We should allow users to customize context menues.
Note: This might be super-flous in the down of the complete re-work of
context menus in 2.0 though.
Comment 9 falko.tesch 2003-10-08 14:11:35 UTC
.
Comment 10 peschtra 2004-07-22 06:04:08 UTC
I think the bookmark command would be nice on a right-click menu too.
Comment 11 lohmaier 2006-07-12 20:59:02 UTC
*** Issue 67160 has been marked as a duplicate of this issue. ***
Comment 12 dkw 2008-01-13 01:22:05 UTC
In particular be able to add Paste Unformatted to the right click context menu
(or any item to a context menu as deep or deeper than Paste Unformatted).
Comment 13 dkw 2008-01-13 01:31:32 UTC
I use Paste Unformatted repetitively and nearly 100% of the time when pasting
data to a spreadsheet or text to a document.  I would not be surprised that many
other users do the same.  Being able to place Paste Unformatted at the top of
the right click context menu would be a welcome feature.  If I knew how to
program features for OO I would attempt to add this feature myself.
Comment 14 tommy27 2008-11-12 21:49:16 UTC
having this feature would be a bless.
Comment 15 andrewprough 2008-11-14 18:41:07 UTC
Ditto dkw on paste unformatted - it would make my work much easier.
Comment 16 eezywriter 2009-01-25 12:31:46 UTC
Hi, I am an author and want to put copy, cut, paste higher in the context menu.
Putting it last is very time consuming.
Word has had this for some time.
Thanks,
P.L. Reiter
Comment 17 tommy27 2009-03-03 09:38:05 UTC
Opera web browser has .ini files for context menus that may be edited by the 
user. a similar solution whould be great in OOo as well.
Comment 18 jcp411 2009-04-28 06:03:50 UTC
Being able to right click on words and get the thesaurus would be wonderful and
would make Writer a lot more of an attractive option!
Comment 19 Mathias_Bauer 2009-08-25 14:57:30 UTC
*** Issue 87661 has been marked as a duplicate of this issue. ***
Comment 20 tommy27 2010-02-12 23:19:50 UTC
is this issue having some consideration 8 years later?

context menus customization would be a kick ass feature
Comment 21 bettina.haberer 2010-05-21 14:46:28 UTC
To grep the issues easier via "requirements" I put the issues currently lying on
my owner to the owner "requirements". 
Comment 22 duus1234 2010-05-25 16:48:45 UTC
If we can't get this done, can we then please get a thesaurus option for context menu?
Comment 23 thadrazdow 2010-08-02 10:27:02 UTC
agree with above. ^^^^^^
                  
Comment 24 noebian 2010-08-20 14:33:44 UTC
free customization of context menus would be great - especially I miss the paste
command.
Comment 25 carsten.driesner 2010-08-20 14:43:52 UTC
cd: Just for your information. We have a volunteer who currently works on
context menus (transition from resource based to XML file format, UNO API
support, etc.)
Hopefully we will be able to provide user interface integration to customize
context menus. For more information please have a look here:
http://wiki.services.openoffice.org/wiki/OpenOffice.org_Internship/Projects/2010/New_Context_Menu_Implementation

cd: Set Ariel on CC and taking over. Set target.
Comment 26 jamison2000e 2010-09-23 03:23:34 UTC
Installed and configured RC/milestone-OOO330m8,
<http://wiki.services.openoffice.org/wiki/Run_OOo_versions_parallel> easy.  The
right click menu Synonyms works great and fast, being able to move it up would
be nice.
Comment 27 Ariel Constenla-Haile 2010-10-02 06:27:08 UTC
accepted
Comment 28 Ariel Constenla-Haile 2010-10-02 06:28:20 UTC
assignment
Comment 29 Ariel Constenla-Haile 2010-10-02 06:28:54 UTC
accepted
Comment 30 radicalchimward 2011-02-16 21:56:40 UTC
quick convenient thesaurus and dictionaries, speed, efficiency, and customized
menus are a MUST for a great, better than the competition, best of the best word
system.

thanks for them improvements
Comment 31 patrick 2011-10-24 07:26:55 UTC
yes... make this possible
Comment 32 Edwin Sharp 2013-11-27 16:09:28 UTC
*** Issue 123762 has been marked as a duplicate of this issue. ***
Comment 33 Edwin Sharp 2013-12-19 18:56:20 UTC
*** Issue 97191 has been marked as a duplicate of this issue. ***
Comment 34 Edwin Sharp 2014-01-15 19:40:54 UTC
*** Issue 102938 has been marked as a duplicate of this issue. ***
Comment 35 Edwin Sharp 2014-01-16 12:36:05 UTC
*** Issue 91570 has been marked as a duplicate of this issue. ***
Comment 36 Edwin Sharp 2014-03-17 18:38:37 UTC
*** Issue 20257 has been marked as a duplicate of this issue. ***
Comment 37 Edwin Sharp 2014-04-24 09:23:24 UTC
*** Issue 46729 has been marked as a duplicate of this issue. ***
Comment 38 Edwin Sharp 2014-05-02 12:22:23 UTC
*** Issue 27709 has been marked as a duplicate of this issue. ***
Comment 39 Edwin Sharp 2014-05-05 05:57:08 UTC
*** Issue 113842 has been marked as a duplicate of this issue. ***
Comment 40 Marcus 2017-05-20 10:45:10 UTC
Reset the assignee to the default "issues@openoffice.apache.org".
Comment 41 oooforum (fr) 2017-10-18 14:47:00 UTC
To be continuted with...

*** This issue has been marked as a duplicate of issue 113382 ***