Issue 74732

Summary: cannot access any HSQLDB data when connection pooling is enabled
Product: Base Reporter: Frank Schönheit <frank.schoenheit>
Component: codeAssignee: marc.neumann
Status: CLOSED FIXED QA Contact: issues@dba <issues>
Severity: Trivial    
Priority: P3 CC: gbotha, ht990332, issues
Version: OOo 2.2 RC1Keywords: regression
Target Milestone: OOo 2.2.1   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Description Flags
document to reproduce the bug case none

Description Frank Schönheit 2007-02-21 14:31:48 UTC
- open the attached database
- open the form therein by double-clicking it
- wait about 10 seconds or so while OOo seems to be frozen
=> crash
Comment 1 Frank Schönheit 2007-02-21 14:39:26 UTC
Created attachment 43237 [details]
document to reproduce the bug case
Comment 2 Frank Schönheit 2007-02-21 14:42:15 UTC
This is a regression relative to OOo 2.1.

Further tests seem to reveal that you cannot open any database forms anymore -
at least none of the ones I tried were successful.

Comment 3 Frank Schönheit 2007-02-21 14:46:09 UTC
Further tests: affects all HSQL databases (which I tried), does not affect the
Bibliography (a dBase database).
For HSQL, not even opening a table succeeeds.
Comment 4 Frank Schönheit 2007-02-21 15:00:21 UTC
further investigations reveal that this happens only when connection pooling is
enable for the HSQLDB driver. This is bad enough, but since the default for this
option is OFF ...
Comment 5 Frank Schönheit 2007-02-22 08:55:42 UTC
fixed in CWS dba23a:
Comment 6 ht990332 2007-02-22 19:15:49 UTC
Patch fixed the issue for me. Thanks fs.
Comment 7 drewjensen.inbox 2007-03-09 05:27:00 UTC
Testing under 2.2RC2 I find that even with pooling disabled I am unable to open
a table using JDBC:hsqldb:file:

I can create the HSQL files, I can create tables I just cannot open these
tables. This is true for both a data view and attempting to issue a select
statement from the SQL window. Checking the location of the data files I find
the log file, with an entry for the connection and nothing further.

If I try to open a table the CPU pegs at 100% for a while then OO.o crashes.
Upon restart file recovery runs, but there is no offer from the application to
send a crash report.

Further, I can use the HSQL database manager to open the file created by OO.o
and populate the tables.

Comment 8 Frank Schönheit 2007-03-12 09:05:54 UTC
that's the same issue, and is fixed in the CWS (dba23a) where this issue here is
Comment 9 Frank Schönheit 2007-03-15 09:47:26 UTC
targeting to 2.3, since the fix is part of a CWS aiming for this release
Comment 10 Frank Schönheit 2007-03-15 11:42:22 UTC
*** Issue 75343 has been marked as a duplicate of this issue. ***
Comment 11 Frank Schönheit 2007-03-21 14:47:31 UTC
fs-> msc: please verify in CWS dba23a
Comment 12 Frank Schönheit 2007-03-21 14:48:36 UTC
fs->msc: note: the attached bug doc is broken, don't know why (try unzipping it,
there will be complaints from your zip tool). However, reproduction is easy with
any HSQLDB database, andy table, any form ..
Comment 13 Frank Schönheit 2007-04-03 11:42:25 UTC
*** Issue 75872 has been marked as a duplicate of this issue. ***
Comment 14 Frank Schönheit 2007-04-04 22:19:17 UTC
*** Issue 75444 has been marked as a duplicate of this issue. ***
Comment 15 gbothawinder 2007-04-05 07:34:34 UTC
I believe I have the same problem listed.
I run OOo 2.2 and MySQL 5.0 with JDBC on XP.
I can link up the database to OOo and see tables etc, but when I open a table, 
it crashes.
I am a complete novice, so I am going to ask a stupid question:
This issue is reported as "fixed" - something to do with source code 
Is this fix accessible to me and if so, how do I go about it or do I have to 
wait for 2.2.1?
Thanks for the information so far.
Comment 16 Frank Schönheit 2007-04-05 07:51:23 UTC
To verify you have the same problem, try the (non-official) fix at,
if you're brave :). Beware, don't use this in a production environment.

The issue is targeted for 2.3, but I'm currently lobbying to get the approval
for 2.2.1, so for an official fix you'll have to wait 'til 2.2.1, at least.
Comment 17 gbothawinder 2007-04-05 08:56:47 UTC
Hey presto!

I copied the .dll into my OOo programs directory after defeating the 
Windows "idiot" minder crap that wanted to prevent me from replacing the 
official dll file and now I can update tables in MySQL just fine!

Thank you very much.
Comment 18 Frank Schönheit 2007-04-16 07:19:11 UTC
*** Issue 75852 has been marked as a duplicate of this issue. ***
Comment 19 Frank Schönheit 2007-04-17 07:32:08 UTC
got release status meeting's approval for 2.2.1
Comment 20 Frank Schönheit 2007-04-17 07:37:50 UTC
copied fix into CWS dba221a:
Comment 21 Frank Schönheit 2007-04-18 09:15:28 UTC
fs-> msc: please verify in CWS dba221a
Comment 22 Mechtilde 2007-04-18 21:00:06 UTC
*** Issue 76487 has been marked as a duplicate of this issue. ***
Comment 23 Frank Schönheit 2007-04-19 19:51:57 UTC
*** Issue 76528 has been marked as a duplicate of this issue. ***
Comment 24 Mechtilde 2007-04-19 19:52:11 UTC
*** Issue 76528 has been marked as a duplicate of this issue. ***
Comment 25 Mechtilde 2007-04-19 19:52:30 UTC
*** Issue 76528 has been marked as a duplicate of this issue. ***
Comment 26 Frank Schönheit 2007-04-20 19:27:21 UTC
*** Issue 76555 has been marked as a duplicate of this issue. ***
Comment 27 marc.neumann 2007-04-23 09:47:12 UTC
verified in CWS dba221a

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System:
Comment 28 kaluscha 2007-05-11 09:51:52 UTC
The fix works for me (OOo 2.2, both Win2K with jre 1.6 and Linux with jre 1.5,
connecting to Oracle 10g XE with ojdbc14.jar).

Thnx, Rainer
Comment 29 drewjensen.inbox 2007-05-22 23:34:10 UTC
Tested with 2.2.1 RC1 and 2.3m_212.