Issue 74820

Summary: Framework - double-clicking any OO file on UNC path just starts OO app, does not open the file
Product: General Reporter: kpalagin <kpalagin>
Component: uiAssignee: thorsten.martens
Status: CLOSED DUPLICATE QA Contact: issues@framework <issues>
Severity: Trivial    
Priority: P2 CC: issues
Version: OOo 2.2 RC1Keywords: regression
Target Milestone: ---   
Hardware: All   
OS: Windows 98   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Illustrating screenshot none

Description kpalagin 2007-02-23 18:16:30 UTC
Happens on both Win98 and WinME. Repro steps
1. Install OO on Win98 or WinME.
2. Click Start\Run, type "\\server\share", OK. Make sure that share contains 
any file of type registered to OO.
3. Double-click that file. Relevant OpenOffice application starts, but file 
does not open, instead application shows "Untitled1" in window title.
4. Clicking File, Open, navigating to \\server\share and d-clicking the file 
opens it just fine.
Does not happen on WinXP. Server name or share name do not contain any special 
chars - actual path used is "\\s05\distrib" and file name is "p1.odt", no 
native lang chars. Both Windows and OO are russian versions.
Comment 1 kpalagin 2007-02-28 22:21:20 UTC
Created attachment 43454 [details]
Illustrating screenshot
Comment 2 kpalagin 2007-02-28 22:42:55 UTC
Additional information:
1. only when trying to open file from NT-based server (1003, XP or 2000) I get 
failure.
2. I see two types of failures:
2.1. If I open \\machinename\d$\folder and d-click "file.odt" I get error 
message (on attached screenshot - path and file are circled in green, note 
that error message cites different path (circled in red).
2.2. If I open \\machinename\share and d-click the file I do not get any error 
message and OO would not open the file either.
3. Opening the file from Win98 server via UNC works just fine.
4. OO 1.1.5 opens file from problematic UNC just fine.
Upping priority because this is regression and very embarassing issue.

Please consider for 2.2.1. Issue is easy to reproduce in virtual machine 
environment.
Also please consider http://www.openoffice.org/issues/show_bug.cgi?id=53184
Comment 3 kpalagin 2007-03-11 13:42:35 UTC
Resolving as dup of http://www.openoffice.org/issues/show_bug.cgi?id=51026

*** This issue has been marked as a duplicate of 51026 ***
Comment 4 kpalagin 2007-03-11 13:43:26 UTC
Closing