Issue 74861

Summary: change template
Product: General Reporter: cppm <foreverwatcher>
Component: uiAssignee: requirements <requirements>
Status: CLOSED DUPLICATE QA Contact: issues@framework <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 2.1   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description cppm 2007-02-25 22:16:22 UTC
ATM if you create a document and later want to updtate the formatting to a new 
template, you either copy and paste the entire document into a fresh document 
made by the template, or you apply the template by 'importing styles' 

now the first method is inconvenient, especially if you have some important 
fields and setup details, such as finely arranged picturing that may get 
trashed by the copy and paste process, or a linked in database, or a document 
description.

The second method means you are condemned to update the styles manually every 
time the template changes, instead of them being updated automagically as they 
should be, this is inconvenient for people like me who have a base of documents 
all formatted to a select set of templates which I may suddenly decide to 
change at some point.

The simplest solution would be to allow the user to refresh the template, thus 
load in all the styles and get the documents 'template' property to point to 
the new template.

I would do this myself, but ATM i'm just a user, and have no experience with OO 
code
Comment 1 thorsten.martens 2007-02-27 09:47:40 UTC
TM->requirements: please have a look, thanks !
Comment 2 thorsten.martens 2007-02-28 09:32:02 UTC
.
Comment 3 claudiadzm 2007-05-03 06:40:08 UTC
Seems to be a duplicate from issue 52783
best regards
Comment 4 cno 2008-02-05 08:55:28 UTC
indeed covered by #52783

*** This issue has been marked as a duplicate of 52783 ***
Comment 5 Mechtilde 2008-11-05 21:02:00 UTC
close the duplicate