Issue 74940

Summary: Can't close "Java Runtime Required" error.
Product: General Reporter: jshanks <jim>
Component: uiAssignee: AOO issues mailing list <issues>
Status: ACCEPTED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, kpalagin
Version: OOo 2.2   
Target Milestone: ---   
Hardware: PC   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Java Setup none

Description jshanks 2007-02-27 21:13:18 UTC
After installing OpenOffice.org 2.2 RC2, I opened a text document and tried
inserting a "Push Button" from the tool bar.

Then right-clicked the button and selected "control", Selected the "mouse button
pressed" selection.  I received an error indicating that the control required
the Java Runtime Environment be installed.  Clicking "OK" on that error
immediately popped up the same error . . . and so on.

There is really 2 problems here.

1.  OpenOffice.org 2.2 didn't pick up my default JRE.
2.  The error dialog wouldn't go away.

I had to open the task manager and kill OpenOffice.org to get the error go go away.

After restarting OOo I was able to select my JRE and everything works fine, but
it may scare the heck out of new OOo users especially since the error doesn't
indicate how to fix it.
Comment 1 michael.ruess 2007-02-28 07:59:43 UTC
Reassigned to MSC.
Comment 2 kpalagin 2007-03-01 14:36:23 UTC
Partially confirming - it takes about 15 OKeys to dismiss the warning about 
Java not being installed.
Comment 3 marc.neumann 2007-05-31 10:49:35 UTC
confirm also, reassign to the right developer.

msc -> fs: can you please assign it to the right developer.
Comment 4 Frank Schönheit 2007-05-31 19:08:50 UTC
fs->ab: Am I right in assuming you're responsible for the script selector dialog
nowadays?
Comment 5 ab 2007-06-01 10:22:13 UTC
ab->jl: Seems to be a Java related problem in the first place,
are there any known issues?
Comment 6 joachim.lingner 2007-06-01 10:48:35 UTC
I think the problem with the error dialog is a known issue. However, the first
problem, that the JRE is not recognized, is new to me. Could you tell me what
JRE do use (from Sun ? which version)? Did you use the Java installer to install it?
Comment 7 jshanks 2007-06-01 14:39:39 UTC
Created attachment 45588 [details]
Java Setup
Comment 8 jshanks 2007-06-01 14:41:41 UTC
I had to manually go into the Java setup (see attachment) and select the JRE
that I wanted to use before OpenOffice would recognize that Java was installed.
Comment 9 joachim.lingner 2007-06-04 08:49:44 UTC
.
Comment 10 joachim.lingner 2007-06-04 08:50:44 UTC
.
Comment 11 joachim.lingner 2007-10-16 08:50:14 UTC
Retargeted to 3.0.
Comment 12 Mathias_Bauer 2008-04-21 16:26:36 UTC
changed component
Comment 13 joachim.lingner 2008-05-30 15:52:52 UTC
Retargeted.