Issue 75445

Summary: Computer with dual monitors Rendering bug when scrolling with mousewheel
Product: Writer Reporter: drhex <jrs>
Component: viewingAssignee: AOO issues mailing list <issues>
Status: RESOLVED IRREPRODUCIBLE QA Contact:
Severity: trivial    
Priority: P3 CC: awf.aoo, elish, issues, khoi.pham108, kpalagin, rainerbielefeld_ooo_qa, rbircher
Version: OOo 2.1   
Target Milestone: ---   
Hardware: PC   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation on: ---
Developer Difficulty: ---

Description drhex 2007-03-16 09:44:50 UTC
To reproduce:
1) Launch openoffice.org Writer with some multi-page document
2) Position open office's window so that a part of it is outside the lower edge
of the screen.
3) Scroll through document using mouse-wheel or the scroll bar at the right edge
of the screen.

Every time the data moves up a notch while scrolling, the same set of pixels is
repeatedly drawn instead of new data appearing.

There is no problem when scrolling with arrow up/down or PgUp/PgDn, or if the
entire window is visible.
Comment 1 michael.ruess 2007-03-16 10:21:33 UTC
Reassigned to SBA.
Comment 2 kpalagin 2007-03-21 16:49:46 UTC
Seems to be dup of http://www.openoffice.org/issues/show_bug.cgi?id=72639
Resolving.

drhex,
please provide screenshot and hardware configuration (especially videocard 
model).

*** This issue has been marked as a duplicate of 72639 ***
Comment 3 micawber 2007-05-31 09:24:14 UTC
Why is this issue marked "RESOLVED"? It is not resolved in 2.2. See issue 72639
Comment 4 drhex 2007-05-31 09:41:02 UTC
This does NOT seem to be a duplicate of 72639 as that issue talks about problems
when scrolling with pgup/pgdn.
My bug does not appear with pgup/pgdn, only with scrollbar or scrollwheel.
The bug appears on the 2nd monitor only , not on the primary monitor.
Primary display 1400x1050,   secondary is 1440x900.  Graphics card is "ATI
Mobility Radeon X1400"
Comment 5 Raphael Bircher 2009-03-30 09:32:42 UTC
closing as worksforme
Comment 6 Raphael Bircher 2009-03-30 09:34:09 UTC
Close issue
Comment 7 drhex 2009-04-01 15:05:32 UTC
I have installed openoffice 3.0.1 and tested again, the problem remains.
To clarify how I reproduce it:

1) on a computer with dual monitors, showing different data in different
resolutions, start open office on the bigger (i.e. the one with more vertical
pixels) monitor
2) Make the window big enough to fill the screen vertically
3) type in some random text, just so there is data on all rows
4) drag the window over to the smaller screen (where all of it won't fit)
5) scroll upp and down in the document by dragging the scrollbar
6) ==> some rows of text gets duplicated on the screen

Scrolling up and down on the big monitor gives no such problem, and neither does
scrolling on the small monitor if I first resize the window to fit there. 
Comment 8 kp 2012-10-03 06:15:19 UTC
I have installed openoffice 3.4.1 and tried to reproduce the bug with 2 screens.
The primary display 2880x1800 and the secondary 1920x1080. I have followed the steps:

1) on a computer with dual monitors, showing different data in different
resolutions, start open office on the bigger (i.e. the one with more vertical
pixels) monitor
2) Make the window big enough to fill the screen vertically
3) type in some random text, just so there is data on all rows
4) drag the window over to the smaller screen (where all of it won't fit)
5) scroll upp and down in the document by dragging the scrollbar
6) ==> some rows of text gets duplicated on the screen

The problem seems to be addressed in the newer version of OOo.
Comment 9 Andre 2014-03-13 16:17:01 UTC
I can not reproduce this bug with a 4.1 developer version.
Comment 10 Edwin Sharp 2014-03-13 16:54:27 UTC
Thank you Andre