Issue 75930

Summary: Unable to select object, placed over an image
Product: Writer Reporter: yavort <yavor01>
Component: editingAssignee: michael.ruess
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues, jian.li, Mathias_Bauer
Version: OOo 2.2   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
An example with a lot of text
none
A fax template. Notice the text in the box to the right, which can not be selected and thus edited.
none
This document is vitrually unsusable, as the picture is locked in the other aplication none

Description yavort 2007-03-30 17:49:12 UTC
Hi,

This has been bothering me for quite a while in OpenOffice.org Writer. It is
often useful to place a background image in a document, which has the size of
the whole page. Reasons to do this might be, for example, that you want to use a
corporate letterhead, exported from the company's ad agency in an appropriate
format (jpg, eps, wmf, emf, etc). I personally work as a graphic designer and
often prepare Corporate Identity related templates for text-editors in this way.

OpenOffice Writer allows setting a background image from the Format-Page menu
point, nevertheless the image can only occupy the area between the margins of
the document. To use the image as a background for the whole page one should set
the margins to 0, making the editing of the text harder (as an indent should be
set for every paragraph and text can not flow from page to page (should be
broken manually or otherwise goes to the page border). 

The easiest way to cope with this is (was also in Word) to place the picture in
the page header, so that it appears on all pages but in the same time remains
fixed in its position. I usually set the appropriate size and position in its
properties, so that I can be sure about the result.

The problem in Writer in this shows when trying to edit the body text of the
page. Any click on the page area automatically selects the background picture
(regardless of its settings - locked or not, background or not), thus rendering
it impossible for the unexperienced user to edit his/her text.

There are only a few ways out of the situation, all of them being pretty
complicated (from a user point of view). One can use the Navigator to select the
text box he wants to edit and then navigate with the arrow keys to get to the
line / word to be edited. The second option is to simply delete the picture
every time you would like to edit the text and reimport it at the end.

Possible solutions as I see them are:
- Add an option in the page properties dialog, allowing for the background image
to take the whole area of the page (not only the area between the margins).
Possibly the easiest sollution.
- Make pictures unselectable when images are turned off (thus allowing to work
on the text and then turn on images. This is not a very intelligent solution,
nevertheless it will probably be a working one.
- Make Writer always prefer selecting the text, when text and image overlap and
a text are is clicked. To select the picture one should click on an part of it,
where there is no text or on the picture border. This is probably the best
solution, yet  guess it will be quite hard to make.
- Introduce a button-click combination, which ignores the uppermost object (or
object selected only with a click) and selects the object under / above it. For
example, when text and picture overlap, ctrl + click selects the text, rather
than as by default i Writer the picture. This will also be useful in the other
way around if the previous solution is established, in order to more easily
select the background picture.
I will attach semple documents to illustrate the issue.
Comment 1 yavort 2007-03-30 17:57:15 UTC
Created attachment 44078 [details]
An example with a lot of text
Comment 2 yavort 2007-03-30 17:58:23 UTC
Created attachment 44079 [details]
A fax template. Notice the text in the box to the right, which can not be selected and thus edited.
Comment 3 yavort 2007-03-30 17:59:19 UTC
Created attachment 44080 [details]
This document is vitrually unsusable, as the picture is locked in the other aplication
Comment 4 yavort 2007-03-30 18:05:36 UTC
While attaching the files I thought, that some might ask in how far is it needed
to create documents without margins (as no printer can actually print them
after). Well, it is very important to do this. In big companies letterheads are
often pre-printed in color and then used as a printer paper. This allows for a
cheaper color print (enhanced with b/w laser printed text) and the usage of
special papers. In this case the letterhead image is only placed in the
template, so that emploees would be able to see visualize the document as it
will be printed and so that an electronic version, identical with the printed
one can be produces. Picture is usually set as a "non-printing object" and thus
only text is being sent to the printer to print on the letterheads loaded.
Comment 5 michael.ruess 2007-04-02 10:15:15 UTC
Already tracked as issue 28595.

*** This issue has been marked as a duplicate of 28595 ***
Comment 6 michael.ruess 2007-04-02 10:15:50 UTC
Closing duplicate.
Comment 7 kpalagin 2007-04-02 13:39:51 UTC
yavort,
I suggest voting for 28595.