Issue 76369

Summary: Non-default pics in Backgrounds are deleted while upgrading OOo to 2.2
Product: Installation Reporter: dma2002 <dma2002>
Component: uiAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: ingo.schmidt-rosbiegal, issues, kpalagin
Version: OOo 2.2   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 33449, 72560    

Description dma2002 2007-04-15 10:24:14 UTC
While upgrading OOo from 2.1 to 2.2 the Clipart is deleted without any
confirmation. But why to delete it? I think, it would be better to save Clipart
if it's already installed.
Comment 1 kpalagin 2007-04-15 20:17:33 UTC
Confirming on WinXP when installing into the same directory - installer 
deletes non-default pictures.
Repro steps:
1. Install OO 2.1.
2. Run Writer - Tools - Gallery. Add picture(s) to Backgrounds folder by 
either D&D from Explorer or r-click Backgrounds - Properties - Add - <select 
file> - Open - OK. Make sure new pic appears in the list of thumbnails.
3. Install 2.2, choosing Custom install and installing into the same directory.
4. Writer - Tools - Gallery - Backgrounds  - non-default pictures are gone.

Changing summary and setting blocking on 
http://qa.openoffice.org/issues/show_bug.cgi?id=72560.
Comment 2 Olaf Felka 2007-04-16 09:59:09 UTC
@ wg: Can you please have a look at this update/gallery problem?
Comment 3 wolframgarten 2007-04-16 10:30:44 UTC
Reproducible somehow. After installing 2.2 in the same directory 2.1 resides in
the writer crashes permanently. But draw runs and does not show the added
graphics in the background theme. But I doubt if this is correct to install the
new version into a directory where already something is in without using a real
update function.
Comment 4 Olaf Felka 2007-04-16 10:39:36 UTC
OOo has a very real update functionality. The feature is working fine in general
but seems to have problems with files in the gallery.
Comment 5 wolframgarten 2007-04-16 15:27:08 UTC
Reproducible. Is this a gallery problem or a setup problem? Reassigned.
Comment 6 Olaf Felka 2007-04-17 09:08:35 UTC
Added 'is' to CC.
Comment 7 wolframgarten 2007-04-17 14:09:01 UTC
I did some testing on this.What I found out:
When graphics are added to standard themes they wont make it into the updated
version. This is intended because at the moment there is no other way to make
sure that an update can install new standard themes with new graphics.
What survives an update are graphics that were inserted into a users theme. They
are stored different and are present after update.
Comment 8 wolframgarten 2007-04-17 14:11:48 UTC
Setting this to later. Although this works like intended it would be nice to
have something like a merge function for the future.
Comment 9 kpalagin 2007-04-17 16:24:27 UTC
So write-accessible default folders are recipie for data loss.
Can we make them read-only at least?
Comment 10 Marcus 2017-05-20 10:55:55 UTC
Reset assigne to the default "issues@openoffice.apache.org".