Issue 76806

Summary: Tri-state check-boxes do not work under GTK
Product: General Reporter: jogi
Component: codeAssignee: jogi
Status: CLOSED FIXED QA Contact: issues@framework <issues>
Severity: Trivial    
Priority: P3 CC: eric.savary, issues, kpalagin
Version: 680m202Keywords: accessibility, usability
Target Milestone: OOo 2.3   
Hardware: Sun   
OS: Unix, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
bug document where mixed SOLID and NONE state hinders UI to uncheck "Object borders" check box none

Description jogi 2007-04-30 12:18:07 UTC
It is not possible in attached test document to uncheck in the "Format" / "3D"
dialog on tab page "Appearance" the "Object borders"-check box (if chart is
activated). The change is only possible if the "Scheme" is changed but
un-checking the checkbox is not persistent.
Comment 1 jogi 2007-04-30 12:19:33 UTC
added keyword
Comment 2 jogi 2007-04-30 12:23:46 UTC
Created attachment 44775 [details]
bug document where mixed SOLID and NONE state hinders UI to uncheck "Object borders" check box
Comment 3 jogi 2007-04-30 13:42:06 UTC
@kla: It seems to be a Solaris issue
Comment 4 jogi 2007-04-30 14:00:18 UTC
The "Tri-state" behaviour isn't possible under Solaris and also not described in
the specification. Under UNIX you can not uncheck the "Object borders".
Comment 5 jogi 2007-05-02 07:39:42 UTC
It is not a chart2 specific issue; it is a general issue and happens also in
other cases in Spreadsheet for example.
@pl: Under GTK the "Tristate-Checkboxes" are not visible; a simple testcase:
1. Open a spreadsheet document
2. Format / Cell / Font Effects 
3. Check "Outline" check-box and press OK
4. Select a cell in neighbourhood to that formatted cell
5. Format / Cell / Font Effects 
6. Check "Shaddow" check-box and press OK
7. Select both formatted cells with the cursor
8. Format / Cell / Font Effects 

BUG: Under GTK (tested several themes) the "tri-state" of both check-boxes isn't
visible. Under Win32 you see that there is the "tri-state" visible.
Comment 6 jogi 2007-05-02 07:46:40 UTC
As obr told me this would be also an A11Y issue.
Comment 7 kpalagin 2007-06-03 07:04:55 UTC
This seems to be dup of http://www.openoffice.org/issues/show_bug.cgi?id=76806
Comment 8 philipp.lohmann 2007-06-03 11:08:23 UTC
kpalagin: Which issue did you actually mean ?
Comment 9 kpalagin 2007-06-03 15:29:51 UTC
This one http://www.openoffice.org/issues/show_bug.cgi?id=75425.
Sorry for confusion.
Comment 10 philipp.lohmann 2007-06-04 15:51:51 UTC
*** Issue 75425 has been marked as a duplicate of this issue. ***
Comment 11 philipp.lohmann 2007-06-06 17:08:40 UTC
The problem here is that gtk does not know a third state of checkboxes. As a
compromise I ended up with with painting the upper half of the control in "off"
state and the lower half in "on" state; these seems to be least offensive with
the themes I used. However at first sight some will probably consider this a
paint error.

fixed in CWS vcl79
Comment 12 philipp.lohmann 2007-06-19 15:13:37 UTC
please verify in CWS vcl79
Comment 13 jogi 2007-07-02 13:39:28 UTC
yes, fixed but we need a better solution to differ the two states better.
Comment 14 thorsten.ziehm 2009-07-20 15:18:25 UTC
This issue is closed automatically and wasn't rechecked in a current version of
OOo. The fixed issue should be integrated in OOo since more than half a year. If
you think this issue isn't fixed in a current version (OOo 3.1), please reopen
it and change the field 'Target Milestone' accordingly.

If you want to download a current version of OOo =>
http://download.openoffice.org/index.html
If you want to know more about the handling of fixed/verified issues =>
http://wiki.services.openoffice.org/wiki/Handle_fixed_verified_issues