Issue 77486

Summary: value of date-fields impossible to change in writer
Product: Writer Reporter: mhatheoo <mh.hh>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: cno, issues
Version: OOo 2.2   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---
Description Flags
reformate a date-entry 1
reformate a date-entry 2 none

Description mhatheoo 2007-05-18 18:49:08 UTC
only opportunity: delete and re-enter
This in both way: enter as digits and format to date aswell as enter as a field


Comment 1 dalo 2007-05-19 10:03:26 UTC
if i correctly interpret your short rant:

ever tried to doubleclick on such a date field ?


Comment 2 cno 2007-05-19 16:33:08 UTC
Hi mhatheoo,
As dalo metions, you can edit by doubleclick.
Also, the contextmenu offers the entry Fields, which leads to the same.
If there is someting special in your case, pls supply detailed information and
an test document or such.
Close as invalid.
Comment 3 mhatheoo 2007-05-21 00:36:13 UTC
nope - not that easy please:

ofcourse that had been tried and
no way - so this had been reopend
did you try it yourself?

Comment 4 cno 2007-05-21 07:03:32 UTC
Of course we tried, Martin.
Thus close as works for me.
Pls, as I asked, attach a test case and give a step by step description.
Then feel free to reopen.
Comment 5 michael.ruess 2007-05-21 08:51:22 UTC
Date fields can of course be edited in Writer.
- double click in left part of the field (double click in right part will do
selection of the field)
- place cursor left of field -> Edit menu (and also context) will offer entry
Comment 6 mhatheoo 2007-05-22 14:33:10 UTC
Well I treat the as unbelievable - my time, isn't it?:

You insert a date-field on 1st April - close the file - reopen it and want to
reedit it to 2nd April : impossible.
(Having correction available is another story)

You insert a date-field, copy its content back as unformated - reedit it - turn
this into a field: impossible

Try to insert date as a user-varibale: strange but working (reopen and serial
date shown/needs to be overwriten)
Try to use a user-variable with date formated other than dd-mm-yy: impossible
You insert a date in a writer-table -any entry and than formated to date
DD-MM-YY - Not seriously working but working (Format will open as TEXT and needs
to be done twice)

You insert a date in a writer-table -any entry and than formated to date in
another format, like leading weekday - impossible to edit

You format a that date back to dd-mm-yy: impossible
use a date-formated cell in writer-table as formula: complicate
use a date-formatted cell other than dd-mm-yy as formula: impossible
some fun-stuff:
Sometimes it happens, that having a cell with and format this to date
with dd-mm-yy-format(31.12.99) it returns with 30.12.99 - have a look at the
attached file.
-- You have a cell formatted as date
-- open context-menu for re-edit number-format: it startes as TEXT
-- set format to date again( 31-12-99) 
looks strange, but gives mostly the expected result - and some overwrites the
content with 31.12.99

Hope you understood that there is something to do - maybe some of the smart
feature been thrown away - but thats another story again.

This in here on W2k with O3 2.1 aswell as 2.2

Comment 7 mhatheoo 2007-05-22 14:36:18 UTC
Created attachment 45314 [details]
reformate a date-entry 1
Comment 8 mhatheoo 2007-05-22 14:37:02 UTC
Created attachment 45315 [details]
reformate a date-entry 2
Comment 9 michael.ruess 2007-05-22 15:26:34 UTC
The problems regarding a certain number format in a table reverts to "Text" (or
any other way) format is a known problem. See issue 63127, issue 54397 and issue

MRU->ES: do we have a possibility to change the "value" of a date field other
than using the unintuitive "Offset" field (or other than re-inserting the field)?
Comment 10 mhatheoo 2007-05-25 16:12:19 UTC
as of OOo dev.2.3 m213

both problems seems to be solved:

Userfield formatted as date can be used and reused in formulas as expected

date in writer-tables seems to work aswell as expected:
default "fall-back-format" is now number, reuse of formatted date-entries is

pls. have a look for yourself. 
but as the change the value of the "default"-date-field would be a nice to have,
you may leave this issue on state "new".


Comment 11 eric.savary 2007-05-30 15:35:46 UTC
Reassigned to Requirements
Comment 12 mhatheoo 2007-06-20 00:26:28 UTC
Hallo es

You should not set it to "requirements" only, as
in 2.2.1 all date-field-handling is brooken, 
and that is a defect 
(solution of 2.3 are not integrated in 2.2.1)