Issue 78023

Summary: import of some MS-Office documents completely destroys OOo GUI
Product: gsl Reporter: wolffc <carsten>
Component: codeAssignee: h.ilter
Status: CLOSED FIXED QA Contact: issues@gsl <issues>
Severity: Trivial    
Priority: P3 CC: hdu, issues, ooo
Version: OOo 2.0.4Keywords: oooqa
Target Milestone: OOo 2.3   
Hardware: PC   
OS: Unix, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Screenshot of OOo-Dev 680m216 (Linux) with the example document loaded. none

Description wolffc 2007-06-01 13:59:38 UTC
Instructions:
1. Open the attached MS-Word Document with oowriter
2. The GUI of all open OOo windows will be completely destroyed:
    - all GUI Strings are gone
    - menubar is empty
    - Parts of open Documents vanish (only in the display, pressing Ctrl+S 
still saves a correct document)

I've seen this happening with ppt documents and ooimpress, too. All the same, 
it allways effects all open OOo windows, not only the ones of a single 
application.
Comment 1 wolffc 2007-06-01 14:13:50 UTC
OK ... the doc is too big to be attached, you can find it here:
http://files.theblindspot.de/this_doc_completely_breaks_oowriter_gui.doc
Comment 2 Olaf Felka 2007-06-01 14:20:06 UTC
Can you confirm this issue with OOo 2.2
(http://download.openoffice.org/2.2.0/index.html?focus=download)? OOo 2.0.4 is
pretty outdated meanwhile. What linux distribution do you use?
Comment 3 wolffc 2007-06-01 15:02:32 UTC
Thanks for the quick answer!

I'm using Debian etch, which has OOo 2.0.4. I don't have the time now, but I 
may try the 2.2.1~rc1-1 packages from Debian unstable in the evening.
Comment 4 wolffc 2007-06-02 13:56:47 UTC
OK. I was able to reproduce this with the OOo 2.2.0 packages for etch from 
backports.org, too. I tried with and without KDE-Integration, same results.

However, the Windows Version 2.2.0 opened the document and stayed fine.

Comment 5 mbayer 2007-06-20 11:53:47 UTC
Can reproduce with OOo 2.2.1 B 9161 Linux i86 RPM (full install) on OpenSuse
10.2 i586 KDE 3.5.5 "release 45.4", and OOo-Dev 680_m216 (same system).
Windows versions do not seem to be affected.

mbayer->wolffc: Can you please reduce your document to the parts relevant for
this bug report, and attach it to this issue please.
Comment 6 mbayer 2007-06-20 11:55:54 UTC
Created attachment 46091 [details]
Screenshot of OOo-Dev 680m216 (Linux) with the example document loaded.
Comment 7 mbayer 2007-06-20 11:58:17 UTC
Confirmed. Setting keywords and priority accordingly.
Comment 8 wolffc 2007-06-20 13:09:13 UTC
> mbayer->wolffc: Can you please reduce your document
> to the parts relevant for this bug report, and attach
> it to this issue please.

I don't know. I can try, but since I don't have MS Office and this seems only 
to be happening with documents created by that program, it might be difficult. 
Oh, and I don't know, which part of the document is responsible, of course. So 
I will probably fail in this task.
Comment 9 thorsten.martens 2007-07-03 14:00:24 UTC
TM->SBA: reproducible, please have a look. Thanks !
Comment 10 stefan.baltzer 2007-07-06 12:25:40 UTC
SBA->HDU: As seen in current dev build 680m217 (on Suse 10.1 with KDE 3.5)
 - this affects all menus (font is invisible)
 - dilaogs come up normally (if you know the keyboard shortcut to call them. :-)
 - Workaround: save document as .odt, Close Office, restart Office, open .odt.
Please proceed.
Comment 11 hdu@apache.org 2007-07-06 13:44:45 UTC
the doc import filter seem to change the UI font => I'll set a breakpoint and reassign this issue when I 
know which source file requests the UI font change
Comment 12 wolffc 2007-07-06 14:23:41 UTC
I think it's some code shared by more than only the doc import filter, I've 
seen this happening with .ppt documents, too. Interestingly, all these 
documents came from the same person. Maybe he is using some seldomly used 
feature in MS-Office.
Comment 13 hdu@apache.org 2007-07-06 15:09:37 UTC
@sba: funny, I saw the problem on your system but cannot reproduce it here though my sytem is quite 
similar...
Comment 14 hdu@apache.org 2007-07-11 18:08:23 UTC
I found the root cause:
- the document contains some text elements with a font attribute that is extremely widely stretched
- the font rasterizer doesn't like these insanely stretched fonts
- ignoring these insanely stretched fonts is better than risking a rasterizer crash
- ignored font instances get an "ignore me" flag
- this "ignore me" flag is unfortunately shared over the whole font face, since it usually happens for invalid 
font files
- in this particular case not the whole font face is bad, just the insanely stretched instance
=>
Fixed in CWS vcl80
Comment 15 hdu@apache.org 2007-07-13 07:46:57 UTC
@sba: please verify in CWS vcl80
Comment 16 stefan.baltzer 2007-07-16 14:21:00 UTC
SBA->HI: As discussed, please proceed. Thanks.
Reassigned to HI.
Comment 17 hdu@apache.org 2007-07-16 15:35:59 UTC
*** Issue 75431 has been marked as a duplicate of this issue. ***
Comment 18 h.ilter 2007-07-20 12:19:58 UTC
Verified with cws vcl80 = ok
Comment 19 h.ilter 2007-08-07 16:04:57 UTC
Still ok in 680m225_9196