Issue 78372

Summary: RPT: it's possible to create (with mouse) a control which is larger than the section it lives in
Product: Base Reporter: Frank Schönheit <frank.schoenheit>
Component: codeAssignee: marc.neumann
Status: CLOSED FIXED QA Contact: issues <issues.openoffice.org>
Severity: trivial    
Priority: P3 CC: issues
Version: recent-trunkKeywords: new_implementation
Target Milestone: OOo 2.3   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation on: ---
Developer Difficulty: ---

Description Frank Schönheit 2007-06-13 11:35:31 UTC
In a the report designer, when creating a control with the mouse, it's possible
to create a control which is larger than the section it lives it: Just move the
mouse outside the section (at the bottom) before releasing it, this will create
a control whose bottom line is outside the section.
This results in a forbidden state, since it's defined that a section is always
large enough to contain all controls completely.
Comment 1 Frank Schönheit 2007-06-13 11:36:06 UTC
This is a new implementation in CWS oj14. Adding keyword "new_implementation".
Comment 2 Frank Schönheit 2007-06-13 13:53:01 UTC
The Report Designer iTeam decided that this issue is a "should fix" for the
first release of the report designer. Targeting to 2.x, thus.
Comment 3 ocke.janssen 2007-07-05 12:57:00 UTC
Waiting for oj14.
Comment 4 ocke.janssen 2007-07-11 11:39:55 UTC
Fixed.
Comment 5 ocke.janssen 2007-07-12 14:06:25 UTC
*** Issue 77078 has been marked as a duplicate of this issue. ***
Comment 6 ocke.janssen 2007-07-20 08:19:52 UTC
Please verify. Thanks.
Comment 7 marc.neumann 2007-07-24 12:36:46 UTC
verified in CWS rpt23fix01

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System:
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=SRC680%2Frpt23fix01
Comment 8 marc.neumann 2007-07-27 12:57:12 UTC
change target to 2.3 because issue will be fixed in a OOO 2.3
Comment 9 drewjensen.inbox 2008-03-15 02:47:51 UTC
Tested w/OOo 2.4 m_11, Kubuntu 7.1 64bit, SRB 1.0.2

Closing