Issue 78455

Summary: use an arabic font for arabic text
Product: gsl Reporter: Joost Andrae <Joost.Andrae>
Component: codeAssignee: Joost Andrae <Joost.Andrae>
Status: CLOSED NOT_AN_OOO_ISSUE QA Contact: issues@gsl <issues>
Severity: Trivial    
Priority: P4 CC: hdu, issues
Version: OOo 2.2.1 RC3Keywords: needmoreinfo
Target Milestone: OOo 3.x   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 79434    

Description Joost Andrae 2007-06-14 13:46:32 UTC
To avoid Glyph fallback display problems the usage of built-in printer fonts
should be avoided

In case of Courier (a monospace font)  is selected as a font (for Arabic text)
there's a problem with the metrics

- since Courier is a printer builtin font it is used for formatting
- on the display a different font is used by glyph fallback
=> incompatible metrics between printer + display
The solution can only be to do better glyph fallback on the printer, which is
very problematic on printers because they don't deal well with glyphids and
non-existant glyphs.

HDU: Since the workaround is very easy ("use an arabic font for arabic text")
and the fix requires major changes, which were planned for SO8/OOo2, I suggest
to retarget this bug.

JA: target for OOo Later
Comment 1 hdu@apache.org 2007-06-15 10:04:05 UTC
In the case of a complex script (like arabic) being written with Courier (or any other monospaced font) I'm 
not really sure how the best approach is. It is obvious that there is a problem, but what would be a 
solution that can be generally agreed on?

1. does the user expect the text to be using Courier glyphs (even if the font doesn't support any arabic)?
2. does the user expect glyphs from another font (supporting arabic), which tries to emulate the 
monospaced metrics of the selected Courier font?
3. does the user neither expect the Courier metrics nor the Courier NotDef glyphs? In this case why did he 
select Courier in the first place?

Are there any good ideas how to solve this problem?
Comment 2 Joost Andrae 2008-07-09 11:25:45 UTC
retarget to 3.1
Comment 3 hdu@apache.org 2008-08-01 11:51:42 UTC
@ja: please provide a bugdoc. On which platforms is the problem confirmed?
Comment 4 hdu@apache.org 2008-10-22 11:53:50 UTC
reassigning. Please see the questions above.
Comment 5 Joost Andrae 2008-10-22 13:20:31 UTC
sorry I have no bugdoc. It's some time ago when I filed this issue. I would ask
Waleed Hosny regarding details
Comment 6 Joost Andrae 2009-01-30 14:39:10 UTC
I cannot remember any reproducible scenario where monospaced fonts are used with
Arabic layout. I set this issue to resolved/REMIND until someone provides a
bugdoc that clearly shows that this issue is an issue. Retarget to 3.x
Comment 7 Joost Andrae 2010-10-22 10:55:56 UTC
closing issue