Issue 79541

Summary: XComponent:dispose() method is hung
Product: App Dev Reporter: bhaskarnaidup <ursbhaskar>
Component: apiAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues
Version: 3.3.0 or older (OOo)   
Target Milestone: ---   
Hardware: Other   
OS: Windows 2000   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
The source document (.odt)
none
The converted pdf document none

Description bhaskarnaidup 2007-07-12 15:16:30 UTC
Hi,

   I am doing a conversion from .odt to .pdf (API 2.2.0), after converting the 
document i am disposing all the resorces using 'dispose()' method of XComponent 
interface.

But the method is hanged ( as if like a deadlock situation).

The conversion is working perfectly and pdf generated is in expacted format.

This scenario is happening when converting a merged Document.
 (I am preparing the merge document working on 'content.xml' and  'styles.xml')

I am not facing this problem when converting non-merged documents as of now 
(Though they are simple documents of maxinmum 6-10 pages)


Thanks

Bhaskar
Comment 1 bhaskarnaidup 2007-07-12 15:18:14 UTC
Created attachment 46729 [details]
The source document (.odt)
Comment 2 bhaskarnaidup 2007-07-12 15:19:19 UTC
Created attachment 46730 [details]
The converted pdf document
Comment 3 jsc 2007-07-16 17:07:31 UTC
I assume that you do it from a remote application, right?

Did you implement your own scheduler for incoming requests. Otherwise threading
problems are likely. You should also use XCloseable.close(...) (query for it at
the document) instead of disposing. 

Maybe you can attach a short example program showing your problem.

Comment 4 bhaskarnaidup 2007-07-16 18:49:29 UTC
Thanks for reply

I am running my own scheduler.  

I have identified the problem.  It is with the 'content.xml' we have generated.  It was having more than 
two styles with same style-name.  

I had fixed it and now its working fine.

But one thing i cant understand is why it is converting properly and then hung at the time of releasing??
It is not throwing any error.  It just hungs up?

I have even tried with 'XCloseable.close().  Still same scenario with corrupt 'content.xml'

Thanks,

Bhaskar
Comment 5 jsc 2007-07-17 07:39:40 UTC
jsc -> tl: it seems to be a writer problem with merged documents. Can you please
check it or reassign it to the right developer
Comment 6 Oliver Specht 2007-08-07 13:06:02 UTC
Target changed to 2.x
Comment 7 Martin Hollmichel 2007-11-09 17:28:04 UTC
set target from 2.x to 3.x according to
http://wiki.services.openoffice.org/wiki/Target_3x
Comment 8 Marcus 2017-05-20 11:27:28 UTC
Reset assigne to the default "issues@openoffice.apache.org".